Issue with dependencies


I’m trying my hand at developing a new component for home assistant :slight_smile:
The component in itself works, but I am having issues getting dependencies right.
Here’s the issue:

HASS requires aiohttp version=>1.1 (1.2 is added in with a currently pending branch, I saw) requires aiohttp version between 1.0 and 1.1

Initially, I would let HASS sort out the dependencies itself, which would automatically download aiohttp 1.0.5 to satisfy’s dependency. The component works fine that way. However, the next time HASS would launch, it would also use this version of aiohttp for itself (frontend, logbook, etc) spitting out errors that it couldn’t find classes which were only added in 1.1.0.

Next I added this line to the component’s python file:
REQUIREMENTS = ['aiohttp==1.1.0','']
Thinking that by forcefully downloading the 1.1.0 version before installing the component would make pip realise it doesn’t need to install 1.0.5. No such luck however. Version 1.0.5 is still downloaded and used. Additionally, using this method would mean I would be downgrading the entirety of the HASS installation to aiohttp 1.1.0, but I thought I’d at least try it as a workaround.

I should also mention that if I remove the .homeassistant/deps/aiohttp folder, everything works as normal. I think this indicates further that the error occurs when dependencies for are installed.

So is there a way to fix this?
Can I somehow tell pip to not install any dependencies and specify them all myself?
Can I use 2 different versions of the same package?

Any help or hints would be greatly appreciated.

Kind regards,