Issue with DuckDNS


#1

Hi All,
I am new to Home Assistant. I have installed HassIO on my raspberry pi3, everything is working great. But i have a problem with remote access. I tried install DuckDNS addon, everithing was working fine, i installed addon, created domain on duckdns.org, setup port forwarding in my router, but when i restarted my HA, i wasnť abble to login to HA. The only way was trought https://hassio.local:8123. I was googling since then, and i found that my ISP using some kind of technology which cannot be used with DuckDNS. My Wan IP in my router is 192.168.88.120 and it´s dynamic, but my public IP (whatismyip.com) is showing as 185.125.130.16, they don´t match up. On my ISP webside, they have written they using multilevel hierarchical dynamic aggregation. Is this reason why i cannot use DuckDNS? Should I pay for public IP, my ISP offers public IP for 2$/month? Is there any possibility to get remote access to my HA, instead of buying public IP? Maybe trough some app using HA Cloud?

Sorry for my english guys, I hope it wasn´t that painful to read this.

Thank you all for your future replyes.


#2

Hey mate,

Your public IP (the one shown to the internet) is always the one on whatismyip.org.

Uninstall everything related to the DuckDNS add-on and start from scratch. Make sure to open port 443 AND port 80 to your Pi’s IP address. Then follow the instructions again and it should work.

Let me know how it goes.
Riley


#3

Please google port forwarding… It device dependent. If you don’t open port, you won’t able to access it outside your network.


#4

i opened ports, it wasn´t working, so then i went googling, i will try it from scratch and let know how it goes


#5

@LavaGlass so i tried it from scratch, i reinstall duckdns, opened ports and it still not working, i can access my HA only with https://hassio.local:8123 i can´t even ping my public IP or mydomain.duckdns.org.
I think that my ISP block ports or has some weird structure, cause my wan ip in my router is 192.168.88.120 which is some internal dynamic ip from my ISP, and the IP from whatismyip.org is not reacheable from my lan.
So i think that only possibility for me i buy dedicated public ip :confused:

config duck_config