Issue with Fibaro FGS223 Dual Switch

Hi guys,

Just started playing with HASS over the last few days on a RPi, and I am having a slight issue with getting it to consistently control a Fibaro FGS223 Dual Relay switch.

I had an initial issue with it being reported as “FIBARO System Unknown: type=0203, id=3000 Switch”, I seemed to overcome this by editing the manufacturer_specific.xml and updating the ID for this device.

Now I have 2 switches like this:

That certainly got me closer to having it all working, however now in HASS I have assigned the 2 Switches into a group and have found that the 6_0_2 is behaving erratically (6_0 seems just fine so far).

If I switch the whole group on (that contains only these 2) they both switch on physically in the switch, however the GUI in HASS generally reports that the 6_0_2 is not on. If I then flick the one switch in HASS it shows that its on (even though the relay is already on).
Similarly, if I turn them both off, then HASS will report that 6_0_2 is still on, but it isn’t. I will need to turn it off in HASS for it to “catchup” to what state the relay is actually in.

I have also performed tests external to the HASS gui by using Postman to manually post the json and turn it on/off. It exhibits the same behavior; 6_0 will correctly reflect the state but 6_0_2 will not.

As I am very very new to this (only got this all working today for the first time) I am unsure how to troubleshoot this issue.

Is there something that I can look at specifically or are there any tips that the pros can give me?

Appreciate it!.

Hi Tim!

I’m experiencing the same (seems to be caused by a OpenZWave issue) problem. See Fibaro double switch (fgs-223) current state not correct

I have opened a ticket at the OpenZWave github. See

Please contribute with your configuration and settings to help the devs solving the issue.

Thanks - glad its not just me.

I will follow this on github and provide details.

I guess you have already tried, but for anyone else searching for similar issues, make sure you update OpenZWave (from GitHub) as there were several issues with the earlier config xml files of the Fibaro fgs-22X switches.

See here: Fibaro Double Switch Showing as one switch

Any update on this issue?

They work. I have 6 of them in the network and they all are good!

Add the switch as Secure Node. Then it works.

I need ot reply to myself. One of the switches is reporting only one switch and the second switch has dissappeard. Restart does not help. Thats strange and very annoying since a few switches are not easy to access, after they have been integrated. Pulling them out of the wall is not something you want to do on a regular base :slight_smile:

Any update? I’m considering buying some of these, and wondering if it is a good idea?

All good. it was a problem with the version of HA at that time. i downgraded and everything was working fine then again.

Did you try updating to version 65 yet? I have had similar problems with a different zwave wall switch and I am hesitant to upgrade

I’ve got this setup today and I’m experiencing this issue running 0.65.5.

Not sure what version people are running that this is working correctly but I’d be interested to hear.

See this thread:

Has anyone had issues adding Fibaro switches to Hassio? Running 0.69 on Raspberi Pi with Aeotec Gen5 USB. I have a Fibaro double switch FGS-223 and Fibaro switch relay FGS-212. I can’t add them to Z wave network, I’ve tried secure mode, tried resetting the to factory, nothing works!