Issue with flashing ESP8266 after soldering

Hi all,

I am new to ESPHome and to soldering in general. I was trying to follow this guide to create a NFC tag reader: I soldered all the connections per the diagram:

When I tried to flash my ESP8266 via ESPHome addon in Home Assistant, I get the following error:

I tried to also flash it with the ESPHome Flasher and I get this error:

I tried to look up multiple solutions and tried different things like different USB ports, different USB cables, running the flasher as an administrator, holding the reset button down while flashing but I continue to get the same errors.

The interesting thing is when I remove all the soldered connections and just plug only the ESP8266 in, I am able to flash it through Home Assistant and the ESPHome Flasher but I don’t see it appear as a device in Home Assistant.

Successful flashing of the ESP8266 with all soldered connections removed

Successful flashing through ESPHome addon in Home Assistant

Any help/suggestions would be very much appreciated. Thank you.

It’s very simple: your wiring is wrong or one of your devices is defective :wink: Double check all your solderings to be sure you didn’t do any bad contact on unwanted contacts between two pins :wink: You can also wire back elements one by one till you have the problem :slight_smile:

I don’t know anything about D1 mini but I know on NodeMCU there are pins used for RX/TX and I’m pretty sure there are pins that need to remain at a known state (high or low) during boot to be able to flash the program.

maybe your wiring sets those pins into an invalid state for flashing.

It might be something to check.

For NodeMCU’s I never hard solder the pins to the circuit. I always use plug in headers so I can remove the board from the circuit to flash it or even replace it if needed.

I started from scratch and it looks like the LED module was the issue. I went ahead and just ditched it and everything is working fine now. Thanks for the tip.

1 Like