Issue with google assistant integration

Have Home assistant 0.65.6. tried configuring google assistant tag on config.yaml.

But the system is expecting these two tags

clientid and accesstoken, wheras the HA wiki says these tags are not required from ver 0.56 onwards.

i have setup an action on my google account and i do get the test action while i try to add the device. But however when i click on that in my mobile phone it gives me a 404 error.

My HA is accessible using https on the web

Per the docs, project_id (not client_id) is required for the component, and api_key is only required to use the google_assistant.request_sync service.

yes i finally got it solved. the issue is because i was using the earlier version of Home assistant
0.65.6. The issue got resolved when i upgraded home assistant to the latest version

The upgrade had its own set of issues. I am running HA on my Raspberry pi (not
the new version requires python 3.6 which is not available in the raspbian distribution. hence had to down load the tar file and install it seperately. then had to upgrade pip to the latest version.
Then while upgrading the home assistant using pip3.6 install --upgrade homeassistant command got an error on the cryptography module from wheels.

I had to upgrade the cryptography module manually using the following commands

sudo apt-get install build-essential libssl-dev libffi-dev python-dev

and then
pip3.6 install cryptography

after then the upgrade of home assistant worked fine.
Post the upgrade i am able to integrate my home assistant with google assistant as per the documentation provided