Issue with Long Lived Tokens

Hi All,

I don’t know where to ask for help and I am not even sure that this is the RIGHT place to do so.

I am that close on giving up on my home-assistant - I have been working with for a couple of months now.

I have installed the latest 0.112.4 version and I was able to work with Long-Lived-Tokens with no issues at all.
Until now - I have created a (Long-Lived-Token) LLT to work with nodered from the beginning and it works great! I must admit that it works from day one.

But day one was when I had several integrations not so many automations and version was before 0.99. Everything was OK.

Then - I have tried to work with Haaska to make Alexa meet my HomeAssistant devices and control them - But with no luck - Tried so many times with LLT and NOTHING happened. the Skill did NOT worked at all. :pleading_face:

I thought that it was bad luck (I did not think that it might be the LLT) and after a while (today) I have tried to integrate the AppDaemon to work with my HomeAssistant and With no luck as well. I was getting Authentication Errors and Disconnecting all the time… I have created so many LLT restart my HA so many time to be able to make it connect with the AppDaemon - And again with no luck. Spending so many hours trying to make it work and NOTHING!

I started to think it might be related to the LLT (10 years tokens) and I was wondering what would happen if I remove the currently working LLT for NodeRED and create a new one and make the connection in NodeRED afterwards…

I deleted the LLT and created a new one - Now it does NOT work as well. I get alerts that there was an attempt to connect with my HA from the nodeRED server BUT no connection.

Now I am that close on giving up - I was hoping that integration with LLT should work Out-of-the-Box with no issues at all - Why they are not working?

I have the latest version 0.112.4 installed, and I am not sure where to begin to understand what went wrong? Both my HA and AppDaemon are on Docker containers.
Please can you assist me?


You did copy the new token into your node-red config, didn’t you?

Yes I did, I have changed the OLD with the new one that I created.

I’m on the same version. I’ll try installing node red tomorrow (getting late here). I’ll then delete the long lived token and replace it (assuming it works the first time). This way we can test if there’s a problem with LLT or just your setup.

Thank you!! Will be happy to see if it works and understand what is wrong on my side. Thank you

I don’t see anywhere that LLT’s are required in the node red addon install.