Issue with Netatmo

Could you please have a look and tell me what is wrong?

2019-01-03 09:37:12 ERROR (MainThread) [homeassistant.components.sensor] Error while setting up platform netatmo
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/”, line 128, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=hass.loop)
File “/usr/lib/python3.5/asyncio/”, line 400, in wait_for
return fut.result()
File “/usr/lib/python3.5/asyncio/”, line 293, in result
raise self._exception
File “/usr/lib/python3.5/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/sensor/”, line 85, in setup_platform
if module_name not in data.get_module_names():
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/sensor/”, line 320, in get_module_names
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/sensor/”, line 360, in update
for module in
TypeError: ‘NoneType’ object is not iterable

Could you post your config? (obviously remove the API key or username password)

api_key: xxx
secret_key: xxx
username: xxx
password: xxx
discovery: false

under sensor:

  • platform: netatmo
    - temperature
    - co2
    - pressure
    - noise
    - humidity
    - temperature
    - humidity
    - min_temp
    - max_temp
    - sum_rain_1
    - sum_rain_24

All looks good to me - more or less identical to my set up. I have noticed since 0.84 I get errors on start up about duplicates on Netatmo, but all the sensors load fine still.

Is this stopping HA from loading?

Are there no Netatmo sensors listed in HA under states (where all the sensors are)?

Is this a new component you have added and what version on HA are you on.

Sorry for all the questions, just trying to troubleshoot :slight_smile:

I have no problems with those questions, basically I should have added all those info when I posted the issue ;-(
hassbian, 0.84.6
It is not stop the HA to load.
It is the first time I try to use the netatmo component.

No sensors listed :frowning:

On netatmo connect is it correct that no Redirect URI and no Webhook URL are defined?

Some logs entries related to netatmo:
2019-01-03 09:37:10 INFO (MainThread) [homeassistant.loader] Loaded sensor.netatmo from homeassistant.components.sensor.netatmo
2019-01-03 09:37:10 INFO (MainThread) [homeassistant.loader] Loaded netatmo from homeassistant.components.netatmo
2019-01-03 09:37:10 INFO (MainThread) [homeassistant.setup] Setting up netatmo
2019-01-03 09:37:11 INFO (MainThread) [homeassistant.setup] Setup of domain netatmo took 0.4 seconds.
2019-01-03 09:37:11 INFO (MainThread) [homeassistant.components.sensor] Setting up sensor.netatmo

Here are my Netatmo Connect settings:

Did you definitely activate it in Netatmo? I know I forgot to do that for my Node Red node. Though looking at your logs it seems it can log on as it is trying to set up the sensors.

Strange, I commented one part of config, restarted and now it is working… strange…

1 Like

Is that the Station name? Just noticed in my config that is commented out too.

I have same issue, can not find way to fix it.
Could you share what did you comment ?

Me too same problem here was working fine yesterday but now I cant get it to load, It has been a little unstable the last weeks but a restart of HA have always solved it before but not now…

I commented out something that was not related to netatmo.
Now I also have issues… I have more the impression that it is random or maybe a netatmo issue…

Same thing here

Had to restart HA for other modification, error with Netatmo sensors since : Error while setting up platform netatmo ( 0.84.6)
I had some values update issues (no updates for few hours), but not working at all now
(Have although a Welcome camera, which is still working)

Same issue right now, after a reboot still no sensors showing from my weather station.

Same issue here

I’ve had a quick look on twitter and i think Netatmo are having an issue currently. My sensors usually work, but i’ve not received an update in 5hours. Same for my Netatmo App

Just Restarted HA, netatmo sensors are back !

Restarted, all my climate sensors are gone. The camera is still working

has anyone found a solution for the missing sensor values? my sensor stopped working some weeks ago. i then checked the netatmo dev panel and had to agree to some new terms. after that they worked, then some days ago they stopped again. i refreshed the keys and that helped. today, same problem again. accessing the netatmo api with my mobile works, but not the ha implentation :frowning:

I have the same issue. After restarting HA, both indoor and outdoor sensors work. After some time, the outdoor values do not refresh, but indoor sensor values are okay. In the Netatmo iOS app, all sensor values are ok.

The next release (0.95) contains a few Netatmo related changes which hopefully remedy at least some of the issue.