Issue with Sonoff Tasmota T1 3 gang

Hi all.
I have a bunch of tasmota devices around, but this one has me beat.
We had a significant power outage, some of them lost their configuration.

For the life of me, I cannot get the 3 gang T1 into AP / pairing mode so i can configure it

The single gangs havent been a problem, no idea what im doing thats different!

Any weird or wonderful hints ?


So i pulled it out of the wall, and reset it back to defaults.
It now works … sort of.

MQTT makes the touch buttons light up, but only the centre button works.
Whats even more odd, this button actuates L1, not L2.

Has the thing shorted out somehow ?
Is there something wrong config wise?

Have you tried reflashing it. Unfortunately with some powerouts there are surges, worste case a surge may have damaged your unit.
Per above try reflashing it, and also have a close look at the board for any obvious sings of damage.

It turns out resetting it did the trick (Reset 5)

The reason it was misbehaving was because the module had actually come a little bit loose, it was only after fiddling a second time around i realised what the issue was.

Explains why MQTT worked, but the actual relays did not!