Issue with Wifi on Raspberry Pi 3B+

Hi !!

I’ve some issues with the Home Assistant installation and more precisely about Wifi connection.

My setup:

  • Raspberry Pi 3B+
  • System install on SSD
  • Home Assistant OS 5.10
  • Core Version core-2021.2.0

I’ve followed this website for the Wifi configuration

My issue is:
My Raspberry Pi connects on my Wifi at the first boot so that’s great, I’ve seen the web page installation process and I’ve created my account and logged in but about 2-3 minutes the Raspberry losts the Wifi connection and I cannot explain why.

I’ve plugged an RJ45 to get an access and in the Supervisor / System / Host the Wifi parameters are correctly configured with my parameters entered in the “my-network” file.

I reboot the Host with Wifi enabled and RJ45 plugged and the Pi get 2 IP addresses reachabled (RJ45 and Wifi) by ping and web access on port 8123 but when I unplug the RJ45 I lost connection on both while the Wifi connection should stay connected …
If I plug the RJ45 back, both connections are UP.

Do you have an idea about this issue?
I’ve already changed the Raspberry Pi, also tried to add a Wifi USB device but that bring me more issues like if I disable the Wifi internal card that’s disable both Wifi Internal and USB…

I’m suffering the same issues since upgrading.

So as you went with a brand new install with same hardware and have same issue with the WiFi dropping.

So your not alone😁

Arf ok, so better install previous version to avoid this?
Any idea of the date fix release?

I recovered from my backup and all working again


Did you re-flash and use the “alternatively restore from a snapshot” to recovere from backup?

I tried reflash and snapshot recovery but even then had WiFi problems hence why I believe something is wrong with the new build for rpi3b.

I recovered my whole SD card from backup using win32diskimager

1 Like

I tried release 5.11 just in case, same issue.
What release are you using?

Core 2021.1.5

Ok thank you ^^, I’m looking for a link to download the release but I don’t find it.
I’m newbie with HA, do you have a link for it?

Sorry I just restored that from backup

no worry, if I find it I’ll put the link down there

1 Like

So Home Assistant OS Release-5 build 9 (Stable) seems working, no wifi down so far.

1 Like

Just wanted to chime in and say I’ve got the same issues here after upgrading last night and then again this morning after restoring my previous setup.

I am having the same issue on a Raspberry Pi 4. I downgraded via ha core update --version 2021.1.5 from the web terminal.

To highlight the issue please comment here