Issue with Zigbee ConBee II (ConBee 2) USB adapter

Tags: #<Tag:0x00007f325cf62aa8> #<Tag:0x00007f325cf628f0>

Hello Everybody,

I’ve just bought the ZigBee dongle in the discussion subject and followed the tutorial here:

https://www.home-assistant.io/integrations/zha/

I’m using Hass.io and this is the configuration entry for the dongle::

zha:
  usb_path: /dev/ttyACM0
  database_path: /config/zigbee.db

(also tried by explicitly setting the radio_type: deconz)

Unfortunately looks like “something went wrong” (quotation) :slight_smile:

This is the Log Entry in the Developer Tools:

Error setting up entry /dev/ttyACM0 for zha
6:33 PM components/zha/core/gateway.py (ERROR)

This is the Log Entry Detail:

Error setting up entry /dev/ttyACM0 for zha

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 190, in async_setup
    hass, self
  File "/usr/src/homeassistant/homeassistant/components/zha/__init__.py", line 107, in async_setup_entry
    await zha_gateway.async_initialize()
  File "/usr/src/homeassistant/homeassistant/components/zha/core/gateway.py", line 124, in async_initialize
    await self.application_controller.startup(auto_form=True)
  File "/usr/local/lib/python3.7/site-packages/bellows/zigbee/application.py", line 113, in startup
    await self.initialize()
  File "/usr/local/lib/python3.7/site-packages/bellows/zigbee/application.py", line 62, in initialize
    await e.reset()
  File "/usr/local/lib/python3.7/site-packages/bellows/ezsp.py", line 55, in reset
    await self._gw.reset()
  File "/usr/local/lib/python3.7/site-packages/bellows/uart.py", line 208, in reset
    return await asyncio.wait_for(self._reset_future, timeout=RESET_TIMEOUT)
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 449, in wait_for
    raise futures.TimeoutError()
concurrent.futures._base.TimeoutError

I SSH into the OS and this is the detection of the dongle in the dmesg:

[  259.060972] usb 1-1.1.2: new full-speed USB device number 7 using dwc_otg
[  259.195504] usb 1-1.1.2: New USB device found, idVendor=1cf1, idProduct=0030
[  259.198510] usb 1-1.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  259.204240] usb 1-1.1.2: Product: ConBee II
[  259.207030] usb 1-1.1.2: Manufacturer: dresden elektronik ingenieurtechnik GmbH
[  259.209843] usb 1-1.1.2: SerialNumber: DE2123128
[  259.217145] cdc_acm 1-1.1.2:1.0: ttyACM0: USB ACM device

Can anybody help me?

Thanks
David

If you go into the Hass.io panel > System > Hardware what USB devices does it show there?

Since mine is /dev/ttyUSB0 on my Raspberry Pi.

You could try setting it up via the Integrations page, rather than using the config yaml, it allows you to choose the radio type and seems to be a validation check of the hardware location. I also did not need to set a path for the database.

I picked up a Conbee 2 to test and set it up using the integration, watch the following. It works perfectly

2 Likes

Nope, i dit find in Hardware /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2128859-if00

but when open in ui i got 502 bad gateway

Same issue here,
Config before save:
device: “/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2193386-if00”

After save

device: >-
/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2193386-if00

Is this normal?

In the logs following info:
09 15:02:41 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:None [Connection refused]
20-05-09 15:02:47 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:None [Connection refused]
20-05-09 15:02:47 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:None [Connection refused]
20-05-09 15:02:54 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:None [Connection refused]
20-05-09 15:03:04 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:None [Connection refused]
20-05-09 15:03:04 ERROR (MainThread) [supervisor.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:8099 ssl:None [Connection refused]

I had it running 1 time, where it asked to configure a password.

Update

It worked eventually with “name”, think there was a space too much.

this one worked perfectly for me on the 0.117 freshly new installed version, thanks!!