Issue with zigbee2mqtt using Aqara door contact

Tags: #<Tag:0x00007f739990b5f0>

Hi,

I am facing issue with zigbee2mqtt to connect an Aqara door contact ( Xiaomi MCCGQ11LM), The first try I was lucky and it was discovered correctly and appeared on my home assistant (Hassio). While changing the the name of the device it sudenly dissapeared. I now tries million ways to add it again with no avail.
However, now I can see only one entity which is the link quality appears and I cannot configure it because it does not have a unique ID!! Maybe from the time I tried to add the sensor from configuration.yaml.
I already have two other Door contacts same model connected through the same zigbee2mqtt they work fine and if I delete them they will be discovered again.
From the log of the zigbee2mqtt I see that the Door contact in question is paired and getting updates:

Zigbee2MQTT:info  2020-09-03 18:42:22: MQTT publish: topic 'zigbee2mqtt/0x00158d00041a3afa', payload '{"battery":91,"contact":false,"linkquality":36,"voltage":2985}'

From My home assistant I can see that the topic reaches it when I listen to the topic (zigbee2mqtt/0x00158d00041a3afa)
I get a message:

Message 0 received on zigbee2mqtt/0x00158d00041a3afa at 6:55 PM:
{
    "battery": 91,
    "contact": true,
    "linkquality": 26,
    "voltage": 2985
}

The zigbee2mqtt configuration:

data_path: /share/zigbee2mqtt
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: true
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://192.168.8.5:1883'
  user: xxxxxx
  password: xxxxxxx
serial:
  port: >-
    /dev/serial/by-id/usb-Texas_Instruments_TI_CC2531_USB_CDC___0X00124B001CCE253C-if00
advanced:
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blacklist: []
ban: []
whitelist: []
queue: {}
socat:
  enabled: false
  master: 'pty,raw,echo=0,link=/dev/ttyZ2M,mode=777'
  slave: 'tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5'
  restartdelay: 1
  initialdelay: 1
  options: '-d -d'
  log: false
  device_options:
    retain: true

The MQTT section from my Home Assistant:

mqtt:
  discovery: true
  discovery_prefix: homeassistant
    birth_message:
        topic: 'hass/status'
        payload: 'online'
    will_message:
        topic: 'hass/status'
        payload: 'offline'