Issue witm Home Assistant Supervised 2021.4.6 intalled on Synology VM DSM 7

Dear Community,

I just begin my journey with HomeAssistant ifso please take that into consideration :slight_smile:

I installed VM on DSM 7.0 beta the Home Assistant Supervised from image version hassos-5-13-ova.
The process itself seems to be easily, I setup everything giving relevant resources (1CPU, 3Gb of RAM). The VM is starting well, initialization process as well and the issue starts here. No matter if I asses through the http://homeassistant.local:8123 or ip:8123 the interface is working dramatically slow, from time to time there is only blank page visible or error message like: “error to load configuration or error to load add ons”.

Here is the piece of log from http server:

Logger: aiohttp.server
Source: /usr/local/lib/python3.8/site-packages/aiohttp/
First occurred: 22:22:53 (1 occurrences)
Last logged: 22:22:53

Error handling request
Traceback (most recent call last):

  • File “/usr/local/lib/python3.8/site-packages/aiohttp/”, line 314, in data_received*
  • messages, upgraded, tail = self._request_parser.feed_data(data)*
  • File “aiohttp/_http_parser.pyx”, line 546, in aiohttp._http_parser.HttpParser.feed_data*
    aiohttp.http_exceptions.BadStatusLine: 400, message=“Bad status line ‘invalid HTTP method’”

And in addition from Supervisor => System => Core:

2021-04-22 22:22:53 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):

  • File “/usr/local/lib/python3.8/site-packages/aiohttp/”, line 314, in data_received*
  • messages, upgraded, tail = self._request_parser.feed_data(data)*
  • File “aiohttp/_http_parser.pyx”, line 546, in aiohttp._http_parser.HttpParser.feed_data*
    aiohttp.http_exceptions.BadStatusLine: 400, message=“Bad status line ‘invalid HTTP method’”

I am not sure is above description is clear enough to help me to find out what is the issue with the performance and strange behavior of the gui interface.

Thanks in advance!

Really nobody? :frowning:

What integrations have you loaded?

What is the chassis load (found under supervisor).

I think minimum requirements is 2cpu but it shouldn’t cause your errors.

Also, what browser are you using perhaps it is a caching in your browser causing this issues.

Hi again,
thank you you found time and went through the issue I have.

Answering your questions:

  • such behavior of the system is visible right after installation if so I can tell there are no add-ons at all. The issue is mostly visible in Supervisor tab or during the login. It takes really long time to load and from time to time is blank page " Error while loading page hassio." or even before put credentials


  • In regards to chassis I am even not able to check because I cannot access hassio tab it’s continuously loading :frowning:

  • I already have tried many ways of running it. First I started from downloading *.ova image and run it as VM using Synology Virtual Machine Manager. Issues as described. Yesterday I decided to download pure Debian 10 image and visualize it on Synology. Then I installed Docker and using the script.

Current dockers which are running:

[email protected]:/home/kalatos# sudo docker ps -a
781e619891fc homeassistant/amd64-addon-configurator:5.2.0 “/init” 13 hours ago Up 13 hours addon_core_configurator
9e75d7db8c10 “/init” 13 hours ago Created addon_a0d7b954_ssh
baa9eaf19aaa homeassistant/amd64-addon-samba:9.3.1 “/init” 13 hours ago Up 13 hours addon_core_samba
c589164cecbe homeassistant/amd64-hassio-multicast:2021.04.0 “/init” 13 hours ago Up 13 hours hassio_multicast
7f7591415d3d homeassistant/amd64-hassio-cli:2021.03.1 “/init /bin/bash -c …” 13 hours ago Up 13 hours hassio_cli
dc0c7ebf5ee4 homeassistant/amd64-hassio-audio:2021.02.1 “/init” 13 hours ago Up 13 hours hassio_audio
fb7da3efd5a4 homeassistant/amd64-hassio-dns:2021.01.0

After refreshing browser many times it starts to work for a while but then same issues.
I manage to buy additional 8GB of RAM on my Synology DS218plus so for sure this is not issue with RAM as I have at latest 4GB. What about CPU? I don’t know. According to the manuals I gave only one CPU keeping second one for DSM itself. I am considering if the CPU upgrde might be the solution but before invest any money I would like to make sure this will be it. Could you please tell your experience while hosting od Synology, how many CPU you give.

The utilization of the CPU and RAM is relatively small:

@fredrike do you plan to release package for DSM7 in the short period of time?

  • according to the browsers I have tried on Firefox, Chrome, EDGE Chromium. For all the browsers same behavior :frowning:

Is there any other place either on Debian or HA I can look the log file and see what is happening?
I would like to start with the integrations but for such unstable environment I cannot. I really do not have idea what more can I check now.

If you could share your voice and experience I will be really grateful! :slight_smile:


If you mean the SPK package is the answer no. There is no longer any ways to run hassio from Synology except from a VM. Home Assistant Supervised (previously known as on Synology DSM as native package (not supported or working atm)

I’m out of suggestions why this doesn’t work for you. @BeardedConti, do you have any suggestions?

Yesterday I gave additional CPU for Debian VM but no difference into behaviour :frowning:
Is there any place that I can get the logs ex. from Debian in order to try to troubleshot?

At the end I will be enforced to by micro computer and make the virtualisation there but better if I will be able to use the Synology device I already have - for sure it will be cheaper solution :slight_smile:

What is wired here nobody has his instance on DS218plus in order to share his experience?


One more update. Now I am able to access Supervised tab:

The weird thing is, it works very randomly and you don’t know what it depends on.

Don’t get me wrong, but you are running VMM on unsupported machine (218play with Realtek processor) on BETA version od DSM 7…
As a matter of fact - even Docker is not supported on play (or j) series of Synology.

No. This is not 218play this is 218plus where both virtualization and docker are officially supported.

The processor is Intel Celeron, here are the details:

Sorry - forgot how to read :slight_smile: Normally it’s 218+ and 218play, so when I’ve just seen p thought it’s play :slight_smile:
What version of VMM are you on - 2.5.3-11366 is latest?

Also, just to repeat - DSM 7 is in BETA and is not suppoed to be run except for experimental use… Even when it is released, I suggest that you wait few months before upgrading to it.


thanks for prompt answer! The version is latest 2.5.3-11366.
I regret updating DSM for several reasons but so far as I understood there is no rollback option and should be stable version soon.

Do you have any other ideas what to check?

Is that possible to install Supervised on Docker instance available in the build in images?

No, Docker version is just HA and you will not get Supervised there.
The only way to officially get HA Supervised is by using VMM.

You should try to run Supervised version installion on Debian 10. Its should work better

Hi @KingRichard, this is exactly how I did it. Now we are speaking about such installation.

Here are the stats righ from Debian:



This is almost not usage :frowning:

Okay so after you install Debian 10, what is your next install? Docker? Then run Supervised?

Docker and then hassio from the script. I’ve used this manual: Installing Home Assistant Supervised on Debian 10

Before I was running the VM right from *.ova taken from HA website but the behaviour was pretty the same.

did you used this installer? GitHub - home-assistant/supervised-installer: Installer for a generic Linux system

how do you install docker? just some advice you should also install portainer to see what happen on the background regarding the supervised

No I used the one from the tutorial which is:

curl -sL "" | bash -s

There is another repo in your link:

curl -Lo

And about docker:

curl -fsSL | sh

Well… In my case, I always used the official HA supervised repo. 2nd you are running the same docker command as mine

Maybe just need to know what happen after you run your system.

P.S. make sure your debian did not have UFW running (usually it will block all your port)


when It comes into the description what is wrong with the HA console. Well slow work is felt, switching between options in the menu takes time. Especially when I try to enter Supervisor tab - one time it loads right after I click into it but most of the time while clicking continuous loading and blank page.

Same with login page. One time when I try to access HA console login menu and login process takes at latest 3 seconds. Next time I am struggling with this wired message like Initializing or loading content - I pestle screen shots few posts above.

seems there is no UFW on my debian instance:

[email protected]:/home/kalatos# ufw status
bash: ufw: command not found
[email protected]:/home/kalatos# ufw
bash: ufw: command not found
[email protected]:/home/kalatos# ufw disable