Issues launching Jupyter Labs Lite addon

Hi,

I installed the Jupyter Labs Addon on hass.io.
My hassio installation is, basically, a docker on an ubuntu server 18.04.

When I try to start the Jupyter Labs Lite addon I get the following error:

 Hass.io Add-on: JupyterLab Lite
 Create documents containing live code, equations, visualizations, and explanatory text.

 Add-on version: 0.2.0
 You are running the latest version of this add-on.
 System: Ubuntu 18.04.2 LTS  (amd64 / qemux86-64)
 Home Assistant version: 0.93.1
 Supervisor version: 164

 Please, share the above information when looking for help
 or support in e.g, GitHub, forums or the Discord chat.

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 11-nginx.sh: executing... 
[cont-init.d] 11-nginx.sh: exited 0.
[cont-init.d] 20-notebooks-dir.sh: executing... 
fatal: cannot change to '/config/notebooks//home-assistant': No such file or directory
fatal: cannot change to '/config/notebooks/home-assistant': No such file or directory
[cont-init.d] 20-notebooks-dir.sh: exited 128.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing... 

            Oops! Something went wrong.

 We are so sorry, but something went terribly wrong when
 starting or running this add-on.
 
 Be sure to check the log above, line by line, for hints.

[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

I don’t know what can I do to fix it so… any help would be greatly appreciated.

Best regards

Update:

So I finally was able to fix the issue but I ran into several other issues as well.

I’m going to describe the proccess I followed in order to fix it:

Firstly I wan’t to incide in the fact that my hass.io installation is on a docker on a ubuntu server 18.04 box. Not a raspberry and the host is not hassos (at least not in the host computer itself)

So I was having this issue in wich the logs said that I coult not change to the correct directory as explained before.

My first step was to delete this directory trough the host ssh interface.

If memory serves me well I deleted: /usr/share/hassio/homeassistant/notebooks
(you can find it by looking for notebooks).

Then I started again the addon and I found that the logs said I was not able to git clone from github.
Since I’m using adguard I supposed that the adguard addon was causing the issue so I stopped it.
Suddenly my DNS queries weren’t working anymore.
I, for some reason I’m still can’t fully understand, I decided to uninstall the adguard addon.

At this moment my box DNS queries wouldn’t work anymore and I couldn’t install adguard again as I was getting a 500 server error when trying to install again adguard.

I tried to install adguard again from a snapshot but the log would say that the image “latest” could not Start typing to replace be found.

I then, in portainer, tagged the adguard image (that luckily I didn’t delete) with the “latest” part and adguard came back to life.

So, basically at this point I knew there was something wrong with my DNSs.

I installed the DNSmasq addon and stopped adguard home.

Then I installed again Jupyter Labs Lite and this time it was working fine.

So, I stopped the DNSmasq addon, started adguard and whitelisted github.com in adguard.

So far it’s been working fine.

I hope this can help someone in the future.

Best regards

1 Like

Thanks for this - you helped me get Jupyter Labs Lite working on my Synology NAS Docker

I had a similar problem to you: I’d installed the add-on as per instructions, but when I connected via port 7777 the connection was refused.

I tried opening the port on the NAS firewall first as I didnt’ know what the problem was - that did nothing.

I then looked in the Docker and on the NAS and saw that Jupyter wasn’t even running! When I started it manually, it stopped again about 10 secs later. Looking in the logs I saw mention of ‘unable to access… /usr/…///home-assistant/…notepad’, same as you.

I mapped to the install folder on the NAS and simply deleted NOTEPAD completely.
All I did to locate it was search the install folder for ‘notepad’ - there was one instance of it, so I deleted it.

When I started it again manually, it cloned from git (as it was supposed to initially I assume) as this time it worked.

When I tried to connect again on port 777 I was asked for username and password as expected.

Thanks so much for your solution for the post; you saved me a lot of time and fidddling.