Issues seeing TS0215A (Zigbee SOS fob)?

Hi all,

Still trying to work my way around the whole Home Automation world and enjoying it so far. :wink:

I recently bought an unbranded version of one of these:

It works in Smart-Life so I know it ‘works’ as such and HA on my RPi3 seems to find it ok (along with the other 25 devices etc):

by _TZ3000_wr2ucaj9
Zigbee Coordinator

IEEE: bc:33:ac:ff:fe:63:xx:xx
Nwk: 0x58c1
Device Type: EndDevice
LQI: 55
RSSI: Unknown
Last Seen: 2021-01-21T14:18:49 (< pressed just before sending this)
Power Source: Battery or Unknown

It found a couple of entities:
What I have renamed ‘Panic button’ and …
sensor.tz3000_wr2ucaj9_ts0215a_power (‘Panic Button battery’)
The latter shows as 100% as of an hour in the future (time stamp timing issue?). That said, taking the battery out for a while and putting it back didn’t seem to be noticed (no gap / drop in the graph)?

However, I haven’t been able to get it to do anything when trying to add it into an automation? What have I missed please? ;-(

Is it like the Sonoff pushbutton switch where the button doesn’t have an entity and you have to capture an event?

Cheers, T i m

Are you trying to use state triggers rather than event triggers?

Erm, ‘quite probably’ I am, judging by your question Tom. ;-(

I think I used what you are referring to (event triggers) with a Sonoff SNZB-01 and I tried to emulate what I did but replacing the bits I could but with no luck.

This is all very new to me and I’m leaning (exploring) new things every day.

How should I proceed in finding out what is needed to be able to use these SOS buttons please? Is there enough into in what I posted and from the link that suggests that the ‘TS0215A_sos’ is supported but mine seems to report as just a ‘TS0215A’?

Cheers, T i m

Actually, I skipped over the mqtt bit. Look like you can create sensors so state triggers should work.

Did you try their double tap example?

  - platform: "mqtt"
    state_topic: "zigbee2mqtt/<FRIENDLY_NAME>"
    availability_topic: "zigbee2mqtt/bridge/state"
    value_template: "{{ value_json.action }}"
    icon: "mdi:gesture-double-tap"

What mqtt broker are you using?

Yes, but I may have entered it incorrectly as I put all 3 sections in and I got a configuration error warning (on the first ‘sensor’ line)?


  • platform: “mqtt”
    state_topic: “zigbee2mqtt/Panic Button”
    availability_topic: “zigbee2mqtt/bridge/state”
    value_template: “{{ value_json.action }}”
    icon: “mdi:gesture-double-tap”

That’s what I just tried to add to configuration.yaml and it gives:

‘duplicated mapping key at line 67, column -204:

Possibly because there is already a ‘sensor’ entry in there (for the date and time, when I was trying to get to the bottom of logs being out of time with the real time) or me doing something very silly? ;-(

What mqtt broker are you using?

Erm, I did look into this and understood that HA comes with one ‘built in’ so I was happy to leave it like that?

This is how big HA is (especially to an old and lowly ex Datacomms support Tech):
This is where I am:


Cheers, T i m

Nope. You have to set one up. Try the Mosquitto addon.

And yes, only one sensor: in your configuration.yaml file.

HI again.

Right, Mosquitto addon, added-on and I assume it self-configures on first run etc.

I’ve removed and re-discovered the fob and added the sensor section in the configuration (re-booted server etc) but nothing seems to have changed? ;-(


  • platform: “mqtt”
    state_topic: “zigbee2mqtt/SOS Button”
    availability_topic: “zigbee2mqtt/bridge/state”
    value_template: “{{ value_json.action }}”
    icon: “mdi:gesture-double-tap”

(Can you have spaces in the friendly names)?

I have tried creating an automation and looked at state and event to toggle a switch with a desk lamp in it but as yet no luck?

Are we sure that this particular device is supported (it doesn’t have the SOS letters on the button or the -sos in the name when discovered) or must it be given it’s ‘found’ with the add-device etc?

I really am in the dark with this as I don’t understand the relationship between the devices / system pre/post adding the MQTT broker etc? ;-(

Could you suggest how you would normally add something like this please in case I’m missing something?

Cheers, T i m

No. Read the documentation.


HI again.

Well, I went back in and there seems to be an automagic feel to it and when I ran their ‘How to test’ bit, it looked like I got the sort of thing back as expected (as much as any of these sorts of guides ever seem to match what I have in front of me etc).

"Message 0 received on home-assistant/switch/1/power at 16:51:


QoS: 0 - Retain: false "

I think I’ll just leave the TP-Link P100 smart WiFi switches to the Tapo phone app and this SOS button to the Smart Life app.

Thanks though.

Cheers, T i m

p.s. I seem to have had more luck flashing a new CC2531 as a sniffer and getting Wireshark running. Only because the walk-throughs worked. :wink:

Em, I’ve just come back to this SOS fob again and re-installed the Mosquitto MQTT broker and it does seem to be as I suggested and a automagic installation (ok, you get it and tell it to install but it needs no configuration (and therefore no need to ‘read the documentation’))? ?

Anyway, the test message seemed to work like before so now I just need to find out how it will help me see the SOS fob etc. :wink:

Cheers, T i m

Just picked one of these up and ZHA picks it up fine. Seems to work okay and treated as an ‘Alarm’ vs a SOS panic button. I guess this could make sense. However the button press ‘triggers’ the alarm, but there is no easy way to reset (disarm). I can see the disarm entity, but it requires a disarm code. …yet no way to set or see the code. Does anyone else have these under ZHA? Eventually it’ll time out and reset at some point.