Issues with HA + node-red

I’ve setup latest Home Assistant to RPi3 and it runs ok. I got to install node-red into it, but ran into a proble, Things seem to run ok, but when I’m adding a call service resouce from the “Home Assistant” palette I end up in an error after giving my credentials to the msg box that opens. Error message says “Cannot GET /homeassistant/services”.

Any pointers / ideas what to do next? I’ve followed the guides found online quite precisely, but hit the wall here. I kind of like the node-red way of building the rules and would really like to give it a try.

My first goal is to get this to work in a small “lab” with just a Philips Hue light installed into it (and that’s working) and start to expand it with Sonoff switches etc.

Thanks in advance.

Marko

Enable the API in your home assistant configuration

Thanks - I have the following in my configuration.yaml

#PASSWORDS
http:
    #http_password: !secret mt_http_password
  
api:
  api_password: !secret mt_api_password

However, I’m still having the same issue. Do I need to somehow specify that this is the HA api I’m referring to? I’m currently writing the config as I understand from the documentation.

One addition:

While checking the configuration for the above, I get following error message:

Invalid config for [http]: [http_password] is an invalid option for [http]. Check: http->http->http_password. (See /config/configuration.yaml, line 39). Please check the docs at https://home-assistant.io/components/http/

Thanks for your help - I’m trying to get to the point where I would have real problems with my configuration / rules, but the setup config seems to be too tough for me… :smiley:

Your syntax on the API password is completely incorrect. Please follow the link that the error message tells you to.

Thanks - did that and returned to an earlier conf that was as the documentation suggests:

#PASSWORDS
http:
    api_password: !secret http_password

api:

I’m still getting the same error with node-red. I’m 100% positive that my PW is as instructed in the secrets.yaml file

What version of node-red are you running? Make sure your version of NODEJS is at least v8.

It shows me v0.18.4 in the node-red UI hamburger menu)

but what does node -v show you from the command line?

I ssh’ed into it and logged in as root --> and get

core-ssh:~# node -v
-bash: node: command not found

So you’re running hassio?

That would have been good info to know, since you don’t actually have access to anything in the host OS.

If you are running the latest hassio and the latest node-red addon, you already have the correct versions of everything. It sounds like your configuration is incorrect somewhere.

Ok - sorry about that. Need to remember to post all the relevant information in the future.

Need to dig deeper into node-red config.

Thanks a lot for your help - I appreciate it.

the node-red config would be in the addon configuration for it.

Yes - I followed pretty much what NOTORIOUS-BDG had on his pages. Will re-check.