Home Assistant Community

Issues with Installing Home Assistant on QNAP Using Docker Container

#1

Hi everyone, I read the guide on installing Home Assistant on the QNAP NAS here: https://qiot.qnap.com/blog/2018/01/22/integrating-home-assistant-qnap-nas/

I’m receiving an error message though and my searches are not returning anyone else experiencing this issue. Just wanted to post here to see if anyone know what was causing this error (screenshot attached)?

Error Messages:

Level Time Category User Message
Error 2019/05/07 07:15:52 Container admin Failed to do background task (create, home-assistant-1)
Error 2019/05/07 07:15:52 Container admin Background task error for create home-assistant-1: unauthorized: authentication required

#2

Are those instructions the same as the official ones here?

#3

Try a home assistant arm based image

#4

Apparently there are 2 QNAP architectures.

#5

Yeah, just like his link said.

#6

Yes, they the same instructions based on my review.

#7

The CPU in my QNAP is an AMD RX-421ND, unless I’m mistaken that’s a x86 processor not an ARM processor. Not 100% confident on that. I’ll give and ARM version a shot if it works though, either way :slight_smile:

Is this the version you are referring to? https://hub.docker.com/r/homeassistant/armhf-homeassistant

#8

Yes that was version
Yes, looks likeRX-421ND is x86

maybe post docker run or docker-compose commands

#9

Yeah, I followed the guide here verbatim. Also tried the ARM version referenced in my last reply. The ARM version installed successfully but the container will not start. The x86 version is still giving the same error: “Background task error for create home-assistant-1: unauthorized: authentication required”

As far as commands go, there isn’t any I’m running. It’s all GUI based on the QNAP Container Station app. Just find the docker version, configure parameters and click create. Per the instructions referenced above and copied below:

  • Install “Container Station” package on your Qnap NAS
  • Launch Container Station and move to “Create Container”-section
  • Search image “homeassistant/home-assistant” with Docker hub and click on “Install”
  • Choose “latest” version and click next
  • Choose a container-name you want (e.g., “homeassistant”)
  • Click on “Advanced Settings”
  • Within “Shared Folders” click on “Volume from host” > “Add” and choose either an existing folder or add a new folder. The “mount point has to be /config , so that Home Assistant will use it for the configuration and logs.
  • Within “Network” and select Network Mode to “Host”
  • To ensure that Home Assistant displays the correct timezone go to the “Environment” tab and click the plus sign then add variable = TZ & value = Europe/London choosing your correct timezone
  • Click on “Create”
  • Wait for some time until your NAS has created the container
  • Your Home Assistant within Docker should now run and will serve the web interface from port 8123 on your Docker host (this will be your Qnap NAS IP address - for example http://192.xxx.xxx.xxx:8123 )
#10

Try pulling the docker image separately.

Looks like it may be unable to pull image from docker hub (unauthorized)

If possible, maybe use command line and try.

Have you reboot machine after Install container station. Maybe that’ll help.

GUI and docker sometimes has quirks. I recommend command line honestly. In a funny way it is simpler when issues occur

#11

So I was able to sort this issue out, turns out the time on the QNAP NAS was off by 10 minutes. Updated the time server and synced and we are running! Thanks for the ideas.