Issues with migration (I think)

Hello all

I was running HA supervisor on a dedicated debian laptop. Since upgrading debian to bookworm i m having issues with automations.

Although i had other issues (such as z-wave devices) i managed to find solutions for them.

In on automation that i use to start my media player, the wake on lan no longer works

Here is a copy of the script
alias: wake htpc
service: wake_on_lan.send_magic_packet data:
mac: 10:7B:44:50:33:80
mode: single
icon: mdi:countertop

in the past on the laptop i did not need to insert the broadcast_address. I inserted it here hoping this would resolve the problem…i did not

The issue, as far as i can tell is that when i run the script I get a false statement and the last 2 digits of the MAC address ar in red.

The mac address of the PC is correct and i verified it with the router map.

I tried to re-insert the MAC address to no avail

I entered the broadcast address to no avail
Each time I restarted Home assistant

I checked the target pc wake on lan function is is enabled and nothing was change on the target pc
What am i missing?

Thank you all for taking the time to respond to this post and help

Well, it’s wrong, so that definitely won’t help :wink:
I guess it should be


but that’s if both HA and the htpc have an 192.168.1.X IP address.

I don’t understand what you mean.

that’s not formatted, and by the looks of it, you’re mixing up a configuration and a script.

For wake on lan, you need to configure a switch, which doesn’t go in a script.

Thank you for your quick response

Nice to know about the broadcast address I will just delete it

With regards to the Mac address
alias: wake htpc

  • service: wake_on_lan.send_magic_packet
    mac: 10:7B:44:50:33:80
    mode: single
    icon: mdi:countertop

The steps detail are as follows

Executed: 7 August 2023 at 10:10:51
domain: wake_on_lan
service: send_magic_packet
mac: 10:7B:44:50:33:80
target: {}
running_script: false

And the step config shows
service: wake_on_lan.send_magic_packet
mac: 10:7B:44:50:33:80

Everything in this script is in a black font with the exception of the number 80 which shows up in red.

This is why i say that this may be the problem

Is there something or a step missing?

read my post

Please, as already asked, format your post.

1 Like

#this is to creates switches as per documentation

this switch is to turn on htpc

- platform: wake_on_lan
name: HTPC
mac: 10:7B:44:50:33:80

Sorry folks to be so obtuse. I do not know what you mean by “formatting”

The above is an exact paste of my switch as it shows up in my /config/switches.yaml with nothing less or nothing more

Again thank you for your patience and understanding

It’s in the FAQ and it’s stickied at the top of the forums.

1 Like