Issues with nest

Overall I’ve always been able to figure out issues with some searching and determination but I’m having a heck of a time getting my nest platform to work. I’ve folowed the configuration page and tried a few suggestions I found on the board making sure the nest developer account and permissions were set up correctly but still not getting any camera images or data. My thermostat seems to be working fine but no sign of the cameras. Anyone else having any issues/point me in the direction of troubleshooting.
The error in the log is attached and my config currently is just the simple required information, client id and client secret.
Thanks for any help.

8-03-26 07:29:06 ERROR (MainThread) [homeassistant.components.binary_sensor] Error while setting up platform nest
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/helpers/", line 82, in async_setup
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/lib/python3.6/asyncio/", line 358, in wait_for
    return fut.result()
  File "/usr/lib/python3.6/asyncio/", line 245, in result
    raise self._exception
  File "/usr/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/binary_sensor/", line 76, in setup_platform
    for variable in conditions
  File "/usr/lib/python3.6/site-packages/homeassistant/components/binary_sensor/", line 77, in <listcomp>
    if variable in BINARY_TYPES]
  File "/usr/lib/python3.6/site-packages/homeassistant/components/sensor/", line 100, in __init__
    self._location = self.device.where
  File "/usr/lib/python3.6/site-packages/nest/", line 234, in where
    return self.structure.wheres[self.where_id]['name']
KeyError: 'UUE-ki3rtzTFIkoNFb_pPIbBneuQoH96VZg096w

Well just like that I updated HA last night woke up this morning and my nest configuration is working wonderfully.