Issues with Sonoff SNZB-03 motion sensor

I have a few Sonoff SNZB-03 motion sensors paired through Phoscon and I set up an automation using HA’s Automation tool, but I have a few questions that I’m hoping someone can help me out with:

  1. Can I create a single automation for turning ON and OFF a light when motion is detected/not detected? At the moment I have 2 separate automations for Motion Detected, and Motion Not Detected which makes my Automations dashboard a bit messy.

  2. The “Turn Off” automation is set to activate after 30 seconds of no motion being detected but what happens is that once it’s triggered, even if I do jumping jacks in front of the sensor, it will not re-trigger the Turn On automation.

I have the Turn On automation set to Mode: Restart and same with the Turn Off automation. I tried Single, I tried Queued but nothing seems to work. Yet the exact same setup with my Hue motion sensors works perfectly fine, I can re-activate the Turn On automation by simply waving my hand, so is it a limitation of the Sonoff sensor?

  1. Is there a way to reduce the “refractory period”, can’t think of a better word, for these units between 2 automation runs?

  2. Is there a way to improve the response time of the sensor? Right now there is a good 1-2 second delay before the lights turn on when motion is detected - again compared to the Hue which is almost instantaneous.

Thanks for any help!

Hi Danzerino, I only have a response for your first question, I also want to know the answer to the rest. I use this setup for my presence detection automations. The automation would trigger every time the state of the binary sensor that is created when you pair the SNZB-03 changes (regardless of what state it changes to). Then, under actions, you can setup a template to decide what to do based on whether the binary sensor’s current state (that it was just changed to) is on or off.

Not sure if this helps at all, but I’ve confirmed the sonoff sensors have a refractory period of 1 minute. I want to know if (and how) I can speed that up too.

Could you please share the automation and how you did the template?

I have similar issues. My SNZB-03 motion sensors are all up and working, however if I move within the 150 second refractory period, the sensor will not re-trigger the automation, meaning the lights will eventually go out when the timer runs out. If I leave the room for the 150 seconds, they will then re-trigger perfectly and without fail every time. So there is definitely something weird going on with these sensors. It is the same for all 6 that I have bought. Anyone any ideas?

i have similar issues. I create an automation in which motion sensor as trigger to turn on the lights of the stairs. I have another automation which turns off the lights of the stairs after 1 minute, whatever triggered the light to turn on.
But my motion sensor is only detecting motion 3 to 7 minutes after the first motion detection.
Very strange :frowning:

Hi all,
In a way good to her you are having similar issues to me.

I’m running HA on a RasPi4, with a CC2531 Zigbee interface. HA is at version 2020.12.07.

I’m quite new to HA, but it does look great.

I’ve had four Sonoff SNZB-02, (humidity / temperature) devices on my system for a few weeks, and they work very well. One does drop off the network now and again, but does self recover.

Like a few of you I now have a SNZB-03 PIR device, and things are not going to plan. I should also say I’m using the integration “Zigbee Home Automation”.

Pairing was simple with no issues.

I’ve added two automatons, one to turn on a light if movement is detected (and the sun is below the horizon). The second automation to turn off the light when the PIR reports no movement.

It all works like a dream, for a while. Then it appears that he PIR stops sending updates. Leaving things alone it does recover, but we are talking many, many hours later. I should say the updates can stop in either state, triggered or clear.

I suspected the problem is in HA and now this has been further strengthened by the evidence that PIR battery level has dropped from 100% to 8% in the last few hours. This is suggesting the PIR is continually sending updates and not getting a response from HA.

I also noticed that a HA reboot fixes the issues for a while.

The PIR is only one meter from the RasPi to test the radio link, my other devices are 10 and more meters away and all still working fine.

Any thoughts or help would be most appreciated.

Regards
Ian

1 Like

I am having problems with the SNZB-03 as well. Pairing went fine but it seems to have lost communication even though it is right next to the CC2531 since I’m still testing the config. ZHA integration as well.

An update to my earlier post. I was assuming the battery was running down because it wasn’t getting acknowledgements from HA. However, this afternoon sat next to the RPi running HA and the PIR sensor next to my hand tests were going to plan. Then, the sensor stopped. No longer did the red LED in the sensor flash when I moved. As far as HA was concerned there was no movement. I now wonder if these sensors have a bug, if only there was a way to know their software version. I now wonder if the software in the PIR is actually locking up in a loop, not detecting movement, not sending an update, and very importantly killing the battery. I know this is a change of thought, but the latest evidence does point to the actual PIR device and not HA. Unfortunately I don’t have an ammeter to hand at the moment to measure the draw from the PIR battery.

1 Like

Folks try this, because it’s working for me at the moment, and it’s hard to believe. It looks like the problem could be associated with the battery connections in the PIR module. I now have two pieces of thin card jammed between the battery and the rear plastic cover. It took a lot of testing to get to this point, and I’m not saying it is the fix, but as yet is working for me.**

5 Likes

I’ve been having problems with one SNZB-03, false triggers etc, i popped a blob of bluetac under the rear cover, seems to have cured it. seeing as i got them all at the same time, all are still 100% battery, cept this one, 100% to 55 - 65 - 35, im hoping this slows that down too

Folks, following my previous post, since placing two pieces of thin card behind the battery my SNZB-03 has worked perfectly. Now that ‘Carnivor’ has post a similar fix, it looks like there is a mechanical issue with the unit. As an electronics engineer myself, I appreciate the very small electrical currents, will not be generating what is known as wetting current effect at the battery contacts. It’s therefore essential to keep the battery and contact clean from grease and have a solid strong connection.

I’ve had more similar issues with my SNZB-02 (Temperature / Humidity) devices over the last few days, so I’ll be trying a few bits of cardboard in them, to see if it stops them from simply dropped off the network.

finding this thread has definitely helped me out, that sensor battery has slowly been climbing now at 70%.

I actually signed up on this forum to comment on this one, finding this fix has saved me some dosh :smiley:

In mid-December 2020, ITEAD replied to a customer question about the behavior of the SNZB-03 and described the intended behavior, including the holdoff time: 60 seconds.

I got a reply from ITEAD basically confirming what we experienced:
"Due to power consumption and power-saving considerations, there have some restrictions on the trigger
That is: when SNZB-03 detects the movement, it will send a signal to ZBBridge
If the device does not detect any movement for one minute, once the device triggered, it will send a signal to ZBBridge
If any movement is detected within one minute, the device will not send a trigger to ZBBridge. And effective detection and trigger signals to ZBBridge will be delayed for one minute. It means the motion sensor works with one-minute intervals."

from: https://github.com/Koenkk/zigbee2mqtt/issues/4874#issuecomment-748796191

I have SONOFF SNZB-03 motion sensor + ConBee II usb stick.
Device was easily discovered using ZigBee Home Automation integration, but now it looks like below in HA:


No motion for 100%, but shows as occupied for most of the time.

Any ideas ? :wink:

You are not alone, my SNZB-03 starts doing this recently too.
It keeps detecting motion.
It worked fine few weeks, but now I have this wired problem.
Maybe battery replacement do the trick.

I gave up on my sonos motion sensor, too unreliable as others have said, have tried that card and bluetack options, tried to move the contacts to make more contact with the battery, just replaced with aqara sensors, however these drop off the zigbee network from time to time, but sometimes work flawlessly for weeks. Using a cc2531 stick.

I have been experimenting with the Ikea motion sensor, I am not well enough versed to compare functions with the two devices you are trying. My experience with the Ikea unit is that is seems to reliably detect motion. Without any activity, it will go to the ZHA offline state after maybe 12 or more hours. But is has always returned to online and full function after detecting something. I have not had to reset it in any way. It was added directly to the coordinator, a Sonoff Zigbee bridge tasmota’ed with ZHA under 2021.1.5. I also have one running natively on Ikea Hub, it to has run fine for maybe 8 months since install.

My knowledge on the sensitivity, range and span of this unit vs. the ones you have again is something I am not able to speak to.

Hope you find something that solves your use case.

I can’t complain about mine

This is my ikea pir sensor. Its report is 100% correct.

pir3

This is one of my sonoff pir:

pir1

This is another sonoff pir:

pir4

These three sensors are placed right next to eachother for testing purpouse.
And the sonoffs are living a life of their own …

2 Likes

What integration do you use ?