ISY994 Config Errors

Hi All. New to Home Assistant, but less new to ISY994i. I started with Hassbian, because my Raspberry Pi was a 3B+ model and the website says only Hassbian works with that hardware currently. Got the ISY devices to load once, but then it stopped working for seemingly no reason, claiming a config error. Ended up trying, turns out it now works on the RPi3B+ hardware now. Configured ISY994 in configuration.yaml, and all devices loaded up the first time. Restarted the Pi, and ever since then, it’s broken again. Nothing was changed in the ISY or in HomeAssistant, but I can’t for the life of me get it to work. I even went so far as to reformat and start again from scratch. Still, it doesn’t work. I get the following message in the error log.

Error during setup of component isy994
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/”, line 145, in _async_setup_component
component.setup, hass, processed_config)
File “/usr/lib/python3.6/concurrent/futures/”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/”, line 381, in setup
use_https=https, tls_ver=tls_version, log=_LOGGER)
File “/usr/lib/python3.6/site-packages/PyISY/”, line 84, in init
self.nodes = Nodes(self, xml=self.conn.getNodes())
File “/usr/lib/python3.6/site-packages/PyISY/Nodes/”, line 52, in init
File “/usr/lib/python3.6/site-packages/PyISY/Nodes/”, line 238, in parse
Group(self, nid, nname, members, controllers), ntype)
File “/usr/lib/python3.6/site-packages/PyISY/Nodes/”, line 43, in init
File “/usr/lib/python3.6/site-packages/PyISY/Nodes/”, line 83, in update
if self.parent[m].status > 0:
File “/usr/lib/python3.6/site-packages/VarEvents/”, line 255, in gt
return self._val > other
TypeError: ‘>’ not supported between instances of ‘NoneType’ and ‘int’

I have read every single post I can find about the ISY and I’ve tried it all. Deleted ISY device folders, added/removed variables, restarted everything, checked the formatting in the configuration.yaml file at least a hundred times. I also tried to update PyISY, but never managed to figure out how to accomplish that.

Can anyone help me out, here? Any advice? ISY version is 4.6.2, and HA is 0.68.1. Is there any older HA version I can revert to that perhaps doesn’t have this issue? Everything else I have tried is working, such as cameras, HAdashboard, etc., I just can’t get ISY to work anymore at all.

Alright, last night in a last hail-mary attempt to fix this, I did a little bit of everything. Added new integer variables, state variables, renamed many of my other variables, added a new dummy program (All in ISY). Reloaded core and restarted the server. All my devices were back and the error was gone!

Devices were still working this morning. Changed configuration.yaml to add some things (unrelated to ISY994), restart, all devices were gone and error was back. Now, no combination of adding, removing or anything that worked last night fixes it. I’m at my wits end! Can someone provide some insight?

is there an xml file associated with this? The underlying error is caused by the PyISY library expecting an integer or None type and it’s getting a string containing ‘>’. This is occuring during a xml node search which possibly validates the xml against the schema. What that means? That particular xml has the wrong data and its producing an exception. Fixing that xml may help, but figuring out what’s causing that xml to have the bad character may also help.

Thanks for your response. at least that gives me something to work with. unfortunately, I can’t find any misplaced ‘>’ symbols in the XML.

It occurred to me that maybe it was having issue with some of the values being 2 or 3 instead of 0 or 1. tried changing everything to 1, no difference. everything to 0, also no difference.

In case anyone else runs into this issue, I have managed to fix it on my own. I ended up renaming all of my devices in the ISY to remove any spaces, then also added 10 more integer variables (I only had one) and 10 state variables (I had 10). I’m not entirely sure which fixed the problem, but I’m leaning towards the variables. Anyway, since making those changes, the ISY994 devices load successfully, every time, even after a myriad of changes to my configuration.yaml file and restarts.

Hi, I see this same error and have tried every fix I could find, including ungrouping devices, removing spaces in names, and I have few dozen state and integer variables. I’ve read on the git for PyISY that this can be caused by how the is written, and there even seems to be fix (39) to that file. I’m running a Hassio docker on an Ubuntu VM, so I’m not sure how I could update the in the container. Looking for some help with this issue. Thanks.

I have seen this a lot. Every time I see an upgrade I do it first chance I get because most of the upgrades fix this issue…until the next reboot of course.
I have tried some of the above too, but it stops working at most reboots and starts working again on its own sometimes and after an upgrade sometimes.
I wish I knew a way for it to come back every time as it sucks to lose all my switches and lights in the house each time I reboot for any reason.

See this issue with PyISY: There is a pending PR for it, but it has not been incorporated yet.

Submitted a PR to update the requirements to the new PyISY version, which includes a fix for this:

Update Requirement for PyISY Package in isy994 Component to v1.1.1 #20349