Isy994i Help

I cannot seem to get my isy994i to integrate into HA

I have the following in config file but it doesn’t seem to work. Any thoughts

  host: https://x.x.x.x:4433
  username: *****
  password: **** 
  tls: 1.2

And the error

   17-03-11 21:52:21 ERROR (MainThread) [homeassistant.setup] Error during setup of component isy994
Traceback (most recent call last):
  File "/usr/src/app/homeassistant/", line 187, in _async_setup_component
    None, component.setup, hass, processed_config)
  File "uvloop/future.pyx", line 230, in __iter__ (uvloop/loop.c:110600)
  File "uvloop/future.pyx", line 432, in uvloop.loop.BaseTask._fast_wakeup (uvloop/loop.c:113980)
  File "uvloop/future.pyx", line 101, in uvloop.loop.BaseFuture._result_impl (uvloop/loop.c:108900)
  File "/usr/local/lib/python3.5/concurrent/futures/", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/app/homeassistant/components/", line 189, in setup
    use_https=https, tls_ver=tls_version, log=_LOGGER)
  File "/usr/local/lib/python3.5/site-packages/PyISY/", line 84, in __init__
    self.nodes = Nodes(self, xml=self.conn.getNodes())
  File "/usr/local/lib/python3.5/site-packages/PyISY/Nodes/", line 73, in __init__
  File "/usr/local/lib/python3.5/site-packages/PyISY/Nodes/", line 223, in parse
    uom=units, prec=prec),
UnboundLocalError: local variable 'units' referenced before assignment

I’m having the same issue in 0.42.4 (Docker). Were you able to get this working landulf?

No luck. I too am running in a docker. Tried everything I can to no avail.

Just got it working now; I had been trying to use http (without the tls option set) in my configuration.yaml file but it looks like the component will only use https (not sure if this is intentional or not).

It does seem to be working now after assigning a self-signed certificate within the ISY994 Dashboard and changing the host in configuration.yaml to https and setting tls to 1.2.

I’m still getting a few “Bad ISY Request” and “Poorly formatted XML” errors in the home-assistant.log on startup, but my devices seem to be showing up as I expect.

Just got the ISY yesterday, so still a lot to learn here. Hopefully it lives up to the hype!

Looks like the errors I had in the home-assistant log were related to a separate issue: isy994 component XML parsing error #2050. After adding and deleting a variable on the ISY those errors went away.

Ultimately though, just getting a proper certificate (self-signed or otherwise) on the ISY resolved this for me.

Update: After adding the self-signed cert on the ISY, HTTP started working also. I tried going back to HTTP in my HA config to troubleshoot delays between the ISY and HA (not sure I’m impressed with the TLS implementation on the ISY), and to my surprise it worked without any issues.