iTach IP2SL


#1

Hi!
I have an iTach IP2SL device to control my Amplifier - how can I get that to work ? I’ve seen the remote device inhass for their IR devices - but nothing about the serial :frowning: can it be used the same way, how should data be formatted if so ?


#2

Serial devices are not supported at the moment. I’d be interested in adding support but I dont have access to an IP2SL device.


#3

@Magnus_Strom would you be interested in testing a custom hass build that supported IP2SL devices? If you are comfortable with that I could attempt to add support and you could try it out.


#4

I have an Itach flex to serial and a flex to IR…

I found these other resources:

I too would love to know how to use the serial command. I am using it to control a projector.


#5

I have tried tinglis1’s IP2SL component which uses the notify framework. Since it needs to pass hex data to the IP socket I had to make some changes, because it was throwing errors. It needs hex characters presented as ascii because the notify framework does not like control characters:
“0B00010401012C01000023” # Mute Bose T20 system

The code in IP2SL needs to be adapted somewhat to ensure this string is turned into true hex. Also the response needs to be trapped and printed to the log for interpretation. I have changed the IP2SL code to reflect these requirements.


#6

I have used tinglis1/home-assistant-custom to change his setup for use with serial devices which require hex commands and respond with hex characters. I have tested this on the Bose T20 serial port with all available key press commands. The solution involves importing base64 as suggested by iTach support.
The hex characters are provided as data in the following format “0B000701C2” as a text string. This is because the notify framework does not send hex characters when they are in the none text character range.
I have made small changes to IP2SL to ensure this ascii string is converted in to hex bytes in python: b’0B000701C2’ and I have left a few lines which can be commented out for debugging purposes.
And finally I have ensured the hex response is properly trapped after sending the command to ensure the programmer can interpret the hex response.
The Bose T20 hex command table and full documentation is available on request.


#7

Alan, I don’t know if you got anybody to test, but I’d be happy to. I have several IP2SL devices I’d like to integrate, and the first one takes really simple commands as shown here: https://parasound.com/pdfs/JC2RS232.pdf. The IP2SL uses two ports: 4998 for control, and 4999 for data to and from.


#8

Did you ever get this working Magnus ?

New to home assistant and this is something I have in my setup, keen to know how best to get it working.

Thanks in advance


#9

Hi!
I never got to try this out - got another system in parallel so got put on the side. Hope to get to it sometime though :slight_smile:


#10

@tinglis1 I found your IP2SL notify procedure in this thread, followed the instructions but I am getting the following error in my logs … you able to help at all ?

2019-02-11 16:54:02 ERROR (MainThread) [homeassistant.components.notify] Error setting up platform ip2sl


#11

I haven’t used my custom component in some time so cannot help with this issue.

You may be able to get the gc100 component to do the same thing though.