ITHO Daalderop FAN RF remote with C1101 and ESP8266

I can test, not dev.
Let me know!

Well, the first step is to obtain a dongle - Home (onlineweb.shop), or you can get ghoti57/evofw3 working with the hardware you have?

Or you can simply run zxdavb/evohome_cc on the hardware/firmware you got - YMMV

Basically, as soon as someone with Itho kit is running evohome_cc, then I’m happy to add all these features.

This is an example of what evohome_cc can capture via ramses_rf:

2021-10-08 09:55:10 INFO (MainThread) [ramses_rf.message] || 32:168090         | 30:082155         |  I | ext_ventilation  |      || {'active': True, '_unknown_0': '0000', '_unknown_2': '00'}

2021-10-08 09:55:14 INFO (MainThread) [ramses_rf.message] || 32:206250         | 30:082155         |  I | switch_speed     |      || {'fan_mode': 'low', 'step_idx': 2, 'step_max': 10}
2021-10-08 09:55:14 INFO (MainThread) [ramses_rf.message] || 30:082155         |                   |  I | vent_31da        | (21) || {'air_quality': None, 'air_quality_base': 0, 'co2_level': None, 'indoor_humidity': 0.69, 'outdoor_humidity': None, 'exhaust_temperature': None, 'supply_temperature': None, 'indoor_temperature': None, 'outdoor_temperature': None, 'speed_cap': 2, 'bypass_pos': None, 'fan_info': 'auto', 'exhaust_fan_speed': None, 'supply_fan_speed': None, 'remaining_time': 0, 'post_heat': 0.0, 'pre_heat': None, 'supply_flow': None, 'exhaust_flow': None}

Here, 32:206250 is a 4-way switch, and 30:082155 is a positive input ventilator.

@zxdavb i have an itho fan and i run your project also for my evohome almost a year.

Right now they are sold out, but I do have an cc1101 868 with esp8266 connected


Can that work?

Also have this

Great! I didn’t think to ask existing users!

Rather than hijack this thread, let’s move discussions to the evohome_cc thread.

The first step would be for you to send me a very recent packet log, and info about your Itho kit. Would you expect it to be implemented as a Fan, or Climate entity, or both?

From evohome_cc’s point of view - you specify a serial port. Just try it and see.

As to if you can load evofw3 on it, you’ll have to ask at github.com/ghoti57/evofw3, I’m afraid.

Did you manage to solve this error? I’ve exactly the same error when using the new updated code.

Nope sorry, i cant get my head around it. If you solved please update here! :hugs:

I got it working again. My pacakages/itho.yaml:

fan:
 - platform: mqtt
   name: Badkamer Ventilatie
   command_topic: "ITHO/Fan/cmd"
   state_topic : "ITHO/Fan/State"
   state_value_template: "{% if value|float==0 %}State 0{% endif %}{% if value|float >0 %}State 1{% endif %}"
   payload_on: "State 1"
   payload_off: "State 0"
   optimistic: true
   preset_modes:
    - "off"     
    - "low"
    - "medium"
    - "high"
    - "full"
   preset_mode_command_topic: "ITHO/Fan/cmd"
   preset_mode_command_template: >
     {% if value == 'low' %}
     State 1
     {% elif value == 'medium' %}
     State 2
     {% elif value == 'high' %}
     State 3
     {% elif value == 'full' %}
     State 4
     {% else %}
     State 0
     {% endif %}
   preset_mode_state_topic: "ITHO/Fan/State"
   preset_mode_value_template: >
     {% if value_json.fan == low %}
     State 1
     {% elif value_json.fan == medium %}
     State 2
     {% elif value_json.fan == high %}
     State 3
     {% elif value_json.fan == full %}
     State 4
     {% else %}
     State 0
     {% endif %}
sensor:
 - platform: mqtt
   name: Badkamer Fan Tijd
   state_topic: "ITHO/Fan/Timer"
   value_template: "{{value}}"
   unit_of_measurement: 's'
 - platform: mqtt
   name : Badkamer Fan Snelheid
   state_topic: "ITHO/Fan/State"
   value_template: >
     {% if value|float==0 %}Standby{% endif %}
     {% if value|float==1 %}Laag{% endif %}
     {% if value|float==2 %}Medium{% endif %}
     {% if value|float==3 %}Hoog{% endif %}
     {% if value|float==4 %}Full{% endif %}
     {% if value|float>=11 %}Hoog(T){% endif %}

group:
 Ventilator:
   entities:
     - fan.badkamer_ventilatie
     - sensor.badkamer_fan_snelheid
     - sensor.badkamer_fan_tijd
3 Likes

Wow, did not see this.
Thanks! at least no errors for now, time to check where the fan controls have gone.

1 Like

Hello guys, currently running a NodeMcu V3 with a CC11010 module connected to it, running the code of @jodur with ESPHome. Works like a charm together with my CVE-S OPTIMA with external CO2 sensor.

But now I have installed a second Itho box for upstairs, off course I want to be able to control it the same way as the first box. So, I soldered a second ESP together with the same code in ESPhome. But the issue I’m having now is that both the boxes react to commands of both ESP’s. I think it is because the code is the same and therefore also the device ID for communicating with boxes.
So my question is, is it possible to make each device unique? If yes, what do I need to change in the code?

Hi all,

First of all thank you to everyone that helped making this possible.

I used to run everything via domoticz, but now I switched to home assistant.
Using the latest packages/itho.yaml script here I got the current status of my Itho showing correctly on my dashboard.

In domoticz I used a virtual switch to control the Itho by sending http commands (state,2 / state,3 etc).

I followed the documentation of the (renewed) Google docs sheet.
But failed to find how to send commands from HA to the Itho.

Can someone please tell me how to do this in HA?
Thanks in advance.

here same issue comming from domoticz and migrating to Hassio

Martin, finally had some time to play arround again. This should now be possible. They have released a new library (https://github.com/arjenhiemstra/IthoEcoFanRFT)were you coud specify the send ID of you device, I will try to integrate this new library so we can use this in the future. Meanwhile i first implemented to long waiting “fix” for OTA updates.

Just released a new verion for ESPHOME

https://github.com/jodur/ESPHOME-ITHO

Changes:

  • New ITHO LIB is used, so the sendID can can be set, so it is possible to use this for several units, as long the sendID differs
  • OTA can now be done without any problems
2 Likes

@jodur, thank you so much! Works great! Now i can control both fans separately. I use a external C02 meter to ramp the fan up when the value gets to high.

My lovelace interface:
image

Hi All,

Is there a option that you can add HA as a virtual Remote into the ITHO ESP?
I have now 2 remotes in ESP added. But want HA also in to this. So when I use HA to control the remote, I see in MQTT the unit back in the payload.

Hi,

I ran into 2 warnings during compile. One related to a deprecated function and one related to missing IthoStandby/DucoStandby.
Fixed them with partial success. Warnings are gone, Standby switch visible, but result for the switch is same as using the low setting.

I know there is a setting to switch it off (it works from my remote, and also worked in the ESPEasy version I was using before swithching to ESPHome)

Any idea where to look to figure out the right setting?

Is it possible to add the fan as a fan instead of a switch?