ITHO Daalderop FAN RF remote with C1101 and ESP8266

here same issue comming from domoticz and migrating to Hassio

Martin, finally had some time to play arround again. This should now be possible. They have released a new library (https://github.com/arjenhiemstra/IthoEcoFanRFT)were you coud specify the send ID of you device, I will try to integrate this new library so we can use this in the future. Meanwhile i first implemented to long waiting “fix” for OTA updates.

Just released a new verion for ESPHOME

https://github.com/jodur/ESPHOME-ITHO

Changes:

  • New ITHO LIB is used, so the sendID can can be set, so it is possible to use this for several units, as long the sendID differs
  • OTA can now be done without any problems
2 Likes

@jodur, thank you so much! Works great! Now i can control both fans separately. I use a external C02 meter to ramp the fan up when the value gets to high.

My lovelace interface:
image

Hi All,

Is there a option that you can add HA as a virtual Remote into the ITHO ESP?
I have now 2 remotes in ESP added. But want HA also in to this. So when I use HA to control the remote, I see in MQTT the unit back in the payload.

Hi,

I ran into 2 warnings during compile. One related to a deprecated function and one related to missing IthoStandby/DucoStandby.
Fixed them with partial success. Warnings are gone, Standby switch visible, but result for the switch is same as using the low setting.

I know there is a setting to switch it off (it works from my remote, and also worked in the ESPEasy version I was using before swithching to ESPHome)

Any idea where to look to figure out the right setting?

Is it possible to add the fan as a fan instead of a switch?

Hi @Hiker,

I am at the exact same point now you were in November last year. I can turn the ITHO on/off through Home Assistant, but the speed will remain low and I haven’t found a way yet to change this to be used in automation.

Have you found a solution in the meanwhile?

Thanks

Alright, it’s fixed. Checked the dupont cables, one was maybe not properly connected, was able to gather the RF id of the remote, added it in ESPEasy, then calling services through HomeAssistant to control fan speed. Works perfectly!

Thanks for the code! I was able to control my Itho fan with your code via Home Assistant after soldering a C1101 to a Wemos D1 mini. A few small questions and things that don’t work:

  1. I have an Itho fan with a humidity sensor, so the fan ramps up after someone takes a shower. With the current code I can only set the fan to low/medium/high, not to auto. Ideally I would like to be able to set the fan to high when the living room CO2 gets too high, but revert to auto instead of low. Do you have an idea what would be required to implement that? I’m happy to write code and test to make it work, but guidance would definitely be appreciated.
  2. When I change the fan speed with the Itho remote, or when the Itho sensor adjusts the speed, I don’t see this reflected in Home Assistant. Is this to be expected, is this only supposed to work when you have multiple boards with your code running on it? I can see the fan speed reflected on one of the Itho sensors, so the unit does send out its current state, but it might just not be processed by your program?

Thanks in advance!