I've tried (almost) everything and can't get an ipv4 address

Howdy,

I’ve been trying to get HA set up for about a month now, and I keep running into the same issue. No ipv4 address showing up when HA boots.

I’ve set up HA multiple different ways, including flashing the SSD (Generic 64), using Proxmox as a VM (both on a Gigabyte Brix) and now VirtualBox with Windows 10 on my regular PC. Each time I’ve gotten HA to boot but I have never got an ipv4 address to put in. Highlighted below is what I’m used to seeing…

When I enter “Network Info”, I see this info pictured below indicating ipv4 is disabled.

image

I’ve tried “Network Update enp0s3 --ipv4-method auto” but I keep getting this error message that the context deadline exceeded. I’ve even gave it the good ol’ reboot by disabling it (which resulted in a “completed” message) and then turning it on with the “auto” command but no luck.

I feel like I’m Christian Bale in The Dark Knight Rising when he’s trying to jump from the pit and keeps falling. I get so close to getting it to work but then quickly snapped back to reality with no ipv4. Please help me defeat the Bane of my existence and help me rise into the glorious world of home automation.

image

Do you have a DHCP server set up (possibly on your router)?

Yep, just confirmed that the router has DHCP server enabled

And what subnet mask does your devices get from the DHCP server?

The Subnet mask is 255.255.255.0

Ok, that should leave plenty of IP addresses to your HA and devices.
Then what networking hardware is in your machines and what network hardware are you setting up for your VMs?

The gigabyte Brix 4770r has both Ethernet and Wifi. I have always had it connected to Ethernet though. Wasn’t able to enable wifi in HA CLI.

With the Virtualbox, I am using my PC (MSI B550 Tomahawk motherboard). I am using Ethernet with the PC too.

The VM network info pictured below:

Hi, I checked this post this afternoon cause I had exactly the same problem
No IPv4 in HA

So I tried the command:
network update enp0s3 --ipv4-method auto
and magically it worked.

I also spent several hours and felt exactly like Christian Bale in The Dark Knight Rising

Perhaps some technical troubles is arising in the comunication of the IPs to HA through VM because it seems exactly the same bug

When working with VMs then make sure that your physical network has a driver that support promiscuous mode, since impersonation might fail otherwise.
Also make sure that the dockers internal network (172.30,X,Y) does not overlap with IP range of the internal network of the VM.
I have fallen into both of these traps in the past working with VMs.

1 Like

@MDMAPAMA I tried the command again with no luck :weary:

@WallyR I can’t seem to find the promiscuous mode in my routers settings. I have a ASUS RT-AX3000, I thought I’ve seen it before but I just scoured through the menus and google and couldn’t find it. I did check to confirm the VM IP wasnt overlapping and it’s not, it’s a 192.168.56.X. so that should be good

Promiscuous mode should be set on the netcard driver on the host system, but if the driver does not support it, then you need another driver.

And regarding the IPs, then know that you might actually have 3 LANs.
One internal LAN in the docker container system, which is connected to the internal LAN of the VM system, unless you have a dedicated netcard only for this (which I would recommend) and that VM internal LAN is then connected to your physical LAN.

Thank you this fixed my problem!

For others - I had this problem with KVM.

I changed networking to direct and this fixed the problem.