JavaScript error while using/testing AppDaemon/HADashboard 4.0.0b1

Tags: #<Tag:0x00007f7392f6aa88>

I recently pulled out my old iPad 1 (the frist classic one) and wanted to use it as another dashboard in my home. After some trying and back and forth I realized that the iPad browser is too old to work properly, so some research later I found out that the dev branch implemented socket.io to support older devices.

I installed it on a test machine and now I’m stuck with the following:
The dreaded Alert “Error getting state, check Java Console for details”
and after checking the console:

Source-Map-Fehler: request failed with status 404
Ressourcen-Adresse: http://192.168.178.73:5050/javascript/socket.io.js
Source-Map-Adresse: socket.io.js.map

I tried a thousand different things and can’t find a solution. Anyone any idea?

Daniel

the first part is checking the logs if appdaemon is actually running.

Yep, it does. I started it manually via SSH to look at the output directly. As you can see there the connection is recognized and the dashboard itself is being served, there’s just an issue with the socket.io.js somehow and I just can’t find out why.

2019-01-07 11:43:18.158302 INFO HASS: HASS Plugin Initializing
2019-01-07 11:43:18.159354 INFO HASS: HASS Plugin initialization complete
2019-01-07 11:43:18.160563 INFO AppDaemon: Initializing HTTP
2019-01-07 11:43:18.161550 INFO AppDaemon: Using 'ws' for event stream
2019-01-07 11:43:18.162632 INFO AppDaemon: Running on port 5050
2019-01-07 11:43:18.220238 INFO AppDaemon: API is disabled
2019-01-07 11:43:18.221063 INFO AppDaemon: Admin Interface is disabled
2019-01-07 11:43:18.221751 INFO AppDaemon: Starting Dashboards
2019-01-07 11:43:18.226362 WARNING AppDaemon: css: /home/homeassistant/.conf/compiled/css is owned by homeassistant but appdaemon is running as root
2019-01-07 11:43:18.229211 WARNING AppDaemon: javascript: /home/homeassistant/.conf/compiled/javascript is owned by homeassistant but appdaemon is running as root
2019-01-07 11:43:18.265101 INFO HASS: Connected to Home Assistant 0.84.6
2019-01-07 11:43:18.272081 INFO AppDaemon: Starting Apps with 0 workers and 0 pins
2019-01-07 11:43:18.482590 INFO HASS: Evaluating startup conditions
2019-01-07 11:43:18.532017 INFO AppDaemon: Got initial state from namespace default
2019-01-07 12:43:20.282633 INFO AppDaemon: Scheduler running in realtime
2019-01-07 12:43:20.296569 INFO AppDaemon: App initialization complete
2019-01-07 12:43:24.210346 INFO AppDaemon: Compiling dashboard 'pad_main'
2019-01-07 12:43:27.473457 INFO AppDaemon: function [get_dashboard] finished in 3339 ms

that could be a cause for problems, if not yet then on the next run.
those directories are for the temperary files and they always have the same names.
so you should stop AD, delete all files there, change to homeassistant user and then start AD.

could also be the cause of your problem when you use the appdaemon user to start the server.

you could check if it is installed right.
you should find the file socket.io.js in the directory
/path/to/where/ad/is/installed/assets/javascript

404 means that the browser is unable to find that file

I deleted the compiled folder as you mentioned and restarted as user ‘homeassistant’ with no luck, the same error still pops up.
Same story goes for deleting and starting as root.

There is no user ‘appdaemon’ on my server, it’s a bit messed up but everything works with 3.0.2

The thing is: I installed it via pip3. And I have literally no idea where the hell it installed itself to. Since the 404 error in itself says that it can’t find the package I would like to put it there. But where? ::smiley:

Thank you already for your suggestions :slight_smile:

Sadly socketio doesn’t work on version 1 iPads, I am planning to add sockjs support which should work ok but I haven’t got to it yet

Ah I see. Then consider this thread as solved since it propably won’t be resolvable at this point.

Thank you for your suggestions! :slight_smile: