Jeelink stick integration

Hi everybody,

I’m doing my first steps with HomeAssistant and coming from FHEM. I’m really impressed about the power of HomeAssistant and have to discover a lot I guess.

I’m trying to move my configuration of FHEM to HomeAssistant and mostly works without problems, Philipps Hue, Tasmota, MQTT it runs :slight_smile:

But I’m trying to get my Technotrend thermometer read in HomeAssistant with my JeeLink USB stick like I did it in FHEM. I put stick to my Raspi4 and I see that it will connected to /dev/ttyUSB0. Then I try to let run pylacrosse as described in docu but pylacrosse scans for hours and found nothing.

HomeAssistant runs in a container on a Raspi4, /dev/ttyUSB0 from Raspi is visible in container of HomeAssistant but I see no devices.

I tried to let run FHEM on same raspi in another container and JeeLink stick is working as usual.

And hints are welcome. Thank yoo for reading so far…

KR alex51

There is the LaCrosse - Home Assistant integration. It works BUT: you have to run a manual scan with pylacrosse and manually add the sensors.

There is no nice way like autocreate or replace battery like FHEM.

More or less the same: GitHub - deveth0/lacrosse-mqtt-gateway: MQTT Gateway for Lacrosse Sensors

But a little less work:
you only put your sensors in the *.ini file like this:

[sensors]
Lacrosse Livingroom = 2

instead

    sensors:
      kitchen_humidity:
        name: Kitchen Humidity
        type: humidity
        id: 72
      kitchen_temperature:
        name: Kitchen Temperature
        type: temperature
        id: 72
      kitchen_lacrosse_battery:
        name: Kitchen Sensor Battery
        type: battery
        id: 72

I’ve tried both ways but I have an initial problem. pylacrosse doesn’t run on my Raspi.

I run:
sudo pylacrosse -d /dev/ttyUSB0 scan

but got no reply from the tool. Waited up to 30 minutes.
Any idea what went wrong here or is there a possibility to debug where the scripts hung?

here’s output of dmesg, device will be recognized:

[    2.266637] usb 1-1.3: new full-speed USB device number 3 using xhci_hcd
[    2.346714] systemd[1]: System time before build time, advancing clock.
[    2.381570] usb 1-1.3: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[    2.381603] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.381620] usb 1-1.3: Product: JeeLink
[    2.381634] usb 1-1.3: Manufacturer: SHK
[    2.381648] usb 1-1.3: SerialNumber: LaCrosse
[    2.466628] usb 1-1.4: new full-speed USB device number 4 using xhci_hcd

Thank you.