Journal issues with supervised install after updating to 2022.11

Don’t think I listed supervised in a VM…

The VM I listed is HAOS.
VMware on win10

The pi3 is HAOS.

The pi4 is barebones supervised.
The pi4 was a fresh install Yesterday.

Although I do have some supervised VMs setup…
It was mostly for testing Bluetooth on my addon, so those are not really recent installs.

Your host operating system in a VM would be listed as HassOS not Debian if you were running HassOS. The images you share show Debian. :man_shrugging:

Unless that’s unrelated.

This is my pi4 no VM.
It is supervised

$ uname -srvmo
Linux 5.10.0-19-arm64 #1 SMP Debian 5.10.149-2 (2022-10-21) aarch64 GNU/Linux

Ok, so your issue is on another machine? I’m just trying to clear up the meaning behind your post.

sudo systemctl status systemd-journal-remote

Shows dead on the HAOS VM and pi4 supervisor.

The pi4 shows the microhttp log spam.
dock64 hostname.

The first status output I posted in that original post had dock64, it should have been haosVM.

The pi3 I presume would also being showing dead, as it has a similar log complaint to the haosVM status command.

The systemctl start command which resulted in the pem error occurred on both setups.

If you’re running HassOS this should be reported as a bug in supervisor. A HassOS system shouldn’t have these issues unless you’re mucking around the os. If you aren’t, it’s a bug.

Anyone else that reads this should treat it as a bug if they too are running HassOS.

The solutions in this thread should only be for a supervised installation.

It was for informative comparison.
Perhaps it is a bug on HAOS… I don’t really have a plain jane barebones HAOS setup atm to check.

I was mainly posting because of the journal log spam and pem error on supervised.

Sorry, I have the same issue but I can’t find out, which 4 lines from which post you are referring to, to solve the log flood.
I believe I tried literally every solution from every post in this thread (my instalation is not unsupported anymore), but my log still gets flooded with

Nov 12 17:49:16 systemd-journal-gatewayd[328373]: microhttpd: Setting TCP_NODELAY option to ON state failed: Operation not supported
Nov 12 17:49:16 systemd-journal-gatewayd[328373]: microhttpd: Setting TCP_CORK option to OFF state failed: Operation not supported
Nov 12 17:49:16 systemd-journal-gatewayd[328373]: microhttpd: Failed to push the data from buffers to the network. Client may experience some delay (usually in range 200ms - 5 sec).

There is no solution for that still. The command lines only help you to solve Unhealthy/unsupported label. The host log spam is still there…


Ditto, my system is classed as healthy, but core logs show those spammed journal messages, systemd-journal-gatewayd is up and running.

1 Like

You may check the size of journal log, if I’m not mistaken /var/log/journal .

So here’s something interesting. I believe that that log spam (all the microhttpd stuff) is only generated when you actually look at the Host log with Home Assistant. If you don’t look at the Host log with Home Assistant and inspect /var/log/journal/xxxx/system.journal with journalctl (sudo journalctl --file /var/log/journal/xxx/system.journal), you don’t see these messages. Once you inspect the Host log through Home Assistant, you see these messages with journalctl.

1 Like

This solution / these commands made the error message go away. It can anyone tell me what the latest HA supervisor version is? Mine is 2022.10.2.

2022.11.2 atm

Thanks. I’m seeing this, and I can’t uprade the Supervisor in any way. CLI says no new update too.

Any thoughts?

HA versions

You’re on the latest supervisor. 2022.11.2 for supervisor is a beta version

1 Like

Ah, ok. Thanks again!

I’m loosing my mind over this issue, as nothing seems to help resolving it. My logs are just growing, system constantly writing to disk (luckily I’m not using SD card, as it would have been burnt for sure)…

Does anyone have any info, is it even dealt with on a developer level? Or where can I report it?

There is an issue opened on GitHub (Supervised installer), but there are so many different informations and (obviously) also different variations of the same issue in the same topic, that I completely lost the track, what’s the issue, what’s the solution and if it’s even posted in the correct repo…

@AdmiralStipe you may edit your /etc/systemd/journald.conf ← SystemMaxUse=50M, to set limit.
And do not open Hosts logs from Home Assistant.

1 Like

Thx for the tip, I changed the setting, will see how it works. But I’m afraid this will only limit the log file size and it’s not really a solution to the actual problem.
Besides, my log files are just growing (and system writes to the disk all the time) regardless if I open the Host logs or not - it’s not induced by viewing Host log, it just does it all the time…