Journal issues with supervised install after updating to 2022.11

Don’t forget to restart journald after changes apply.
When you opens a Hosts logs in HA u will get spam to journald logs from microhttpd with “Setting TCP_NODELAY option to ON state failed” and etc.
The logs growing it is the nature of logs, but if you consider it’s explicit you should dive deeper to find the reason.
I’ve was pressed to migrate from micro SD card to another solution after I’ve lost mine SD card and should reinstall all system again.

1 Like

after updating i had like 9 warning messages but thanks to this thread and hassio’s own web ressources i was able to resolve all of them but one: Unsupported system - Operating System – which will probably stay on a raspbian buster bullseye supervised installation.

anyway thank you very much to everyone involved here <3

Indeed since Buster is not supported anymore.

If this bothers you upgrading Buster to Bullseye, at least if your initial installation is based on this guide should be painless when using these instructions.

thanks for the reply. now that you mentioned it i realized that i mixed up the two; in fact i am already running Bullseye. upgraded via apt full-upgrade (not the links you posted unfortunately)

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"

alas the error message is still there. any idea how to fix this? would be much appreciated. thanks again
Screenshot 2022-11-27 133225

What exactly is shown when clicking on that Unsupported system - Operating System-message?

Also make sure you have the latest OS-Agent installed which is v.1.4.1.

To see installed version:
Settings → System → Repairs → 3 dots at the upper right corner → Information about system

Scroll down to section Home Assistant Supervisor

It should read:

If you have an earlier version installed upgrade OS-Agent to the latest available version. About how to do that check again the last section of my above mentioned Debian upgrade guide.

Restart the host after you have upgraded OS-Agent.

once again thank you for your reply:

this is the operating system error:
Screenshot 2022-11-27 142319

while fixing the other error messages i reinstalled OS agent already and even the supervised installation script again. system settings seem to confirm this
Screenshot 2022-11-27 142451

What is
sudo uname -a

 sudo uname -a
Linux rpi 5.15.76-v7l+ #1597 SMP Fri Nov 4 12:14:58 GMT 2022 armv7l GNU/Linux

Well, I just noticed:

Raspian GNU/Linux 11 (bullseye)

:point_up_2:t3: That is the problem.

While Raspian is based on Debian, it is not Debian but a Debian derivative. Thus there is no way to eliminate that “Unsupported System”-message. Either you will have to live with it or change the underlying OS to Debian 11 (but not a derivative) :cry:


yup that’s what i reckoned after having read up on it before. but you sounded so full of hope :smiley:

anyway thanks for your response

You’re welcome.

Oups, sorry about that.

If you have an issue with the size of journal files, I use this script from time to time to fix them:

# To see current disk usage
journalctl --disk-usage
# The safest way to remove unessesary entries is via the journalctl:
journalctl --vacuum-size=128M
# After that you can verify if everything is still intact:
journalctl --verify

BTW, if you have set the size in the journal configuration, maybe it is not necessary, but for those who haven’t, usually, journal files keep growing and occupying the file system.
I have the bug on the host log file, if you watch it from HA, but I almost never use that feature: I resolved forcing a reinstall of the packages involved and a lots of reboots :smiley:
Hope this helps.

1 Like

My log file says it’s only 4 Gb’s, but today I tried doing a home assistant backup and in the matter of about 6 hours the backup failed and my disk usage literally jumped 200 GB’s.

Struggling to understand what is happening. I have the same warnings.

to Fix The unsupported error despite having reinstalled the relevant package and supervisor installer package. Having manually chekced /usr/lib/systemd/system/systemd-journal-gatewayd.socket the cotents did not tally with supervised-installer/systemd-journal-gatewayd.socket at 10b1819f05da9aa86a1f683cc8702d9449eda472 · home-assistant/supervised-installer · GitHub socket line was wrong updating the file manually worked for me.


@pssc , can you clarify what is wrong in the file?

The contents did not match the github repos version assuming I still had the os package version somehow…

Thanks, I did that change but still have the issue show up… not sure what else is an issue.

I have the same error

I don’t have any errors or problems any more.

nice find!

Also updated manually and reboot and resolved the Repair error…