Just upgraded to 0.76.0 no Zwave now

Just got this after upgrading. I looked through the breaking changes and I don’t see anything about Zwave in there.


Also this error in my logs:

Unable to install package python_openzwave==0.4.9: Command "/srv/homeassistant/bin/python3.6 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-37it0z4y/python-openzwave/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-xepg3qa4/install-record.txt --single-version-externally-managed --compile --install-headers /srv/homeassistant/include/site/python3.6/python-openzwave" failed with error code 1 in /tmp/pip-install-37it0z4y/python-openzwave/

Anyone have an idea of what happened and how to fix?

I would try changing to your virtual env and manually installing python_openzwave to see if that fixes it.
pip3 install --upgrade python_openzwave==0.4.9

I would shut down the HA service before installing.

Hey thanks. I just tried to manually install and got this error.

fetching https://raw.githubusercontent.com/OpenZWave/python-openzwave/master/archives/open-zwave-master-0.4.9.zip into openzwave-embed/open-zwave.zip for version 0.4.9
    error: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:777)>

Are you using a patched version? Any environmental variables set?

I just successfully ran
pip3 install --upgrade python_openzwave==0.4.9

Its just installed in debian on a Pine64. Not sure what you mean patched version?

I have to travel for a few days. Reverted back to my backup image for now.
Will see if I can fix it when I get back. Thanks

I’ve the same issue too. Did you managed to get it fixed? Thanks.

No.I moved all my Zwave over to my Wink Hub for now.

Its usually just a different usb port setting. I just plug my usb z wave controller into a different port.

Having the same issue now with 0.79.3

Weeks ago my installation in venv was also broken. Reason for me was that in the end of 2017 I installed manually a python 3.6 version. In meantime I did a OS - update and some dependencies got lost (to debian stretch) because default python in debian 9 is python 3.5.
My solution was reinstalling HA after saving configuration. I just deleted the old pyhton 3.6 binaries before new installation of HA.

I also had this issue, but I changed my usb zwave controller device ID in configuration.yaml and it worked, for some reason it sometimes sees it in as devACM0, 1 or 2 when restarting the Ubuntu VM…