Just went through the Alexa Smart Home setup and got stuck a "discover Devices"

As for ssl, are you using DuckDns? If so, you need to port forward 443 external to 8123 internal on your HomeAssistant ip address.

By entities, do you mean known devices?

If I delete known devices and let it repopulate could that help?

Is there anything besides media_player that interferes? If so I will check that, but I have no media players in my known entities.

I used DuckDNS but I set up everything through 8443 instead of 443 to keep 443 open.

I mean entities. This would be seen/filtered from the home assistant side.

I’m not sure what you mean by ‘known devices’ . Do you mean the devices on alexa’s side?

Not that i know of.

Are you putting the port in everything for the alexa configuration?

Ahh thanks for the clarification. I have two showing up, my samsung tv and my nvidia shield. Can I disable them somehow to see if that fixes it?

Yes, and it works fine from the “test” code.

Yeah, try that. from what I’ve seen media_players are the only issue at the moment. And it’s not all media players with the issue.

Whats the best process to disable them?

Trying to find out what methods to disable media player would work.

I tried disabling from the front end but that didnt do the job.

Disable them through the configuration I posted before with the include/exclude entities.

If that doesn’t work for you check what region your lamba function is in. I had the exact same experience in the Oregon region but when I recreated in the Virginia region everything worked great.

I am oregon. I will try changing to virginia… is that just a swap or do I have to recreate everything?

There was no move option for me but I’m not a big AWS guy. I had to recreate everything in the new region.

FFFFfffffjuuuuuuu

That totally worked. Switched to Viginia (from Oregon). Copied and pasted everything over. Discovered devices. Boom.

Thank you to BOTH @krinehart & @petro for spending so much time trying to help me out.

Nice! Glad it worked.

So after accidentally discovering 750+ devices due to what I believe was incorrect spacing on my exclude filter… I am nervous to run discover devices again… is there a way to verify what entities are exposed before-hand similar to api/pi/lights or whatever it is for emulated hue?

Good question… Not sure. I’ll have to dig into that.

1 Like

So apparently something is still not right with my filter… it just discovered all my devices/entities again… is there something I am doing wrong here?

smart_home:
  locale: en-US
  endpoint: https://api.amazonalexa.com/v3/events
  client_id: ##############
  client_secret: #################
  filter:
    include_entities:
      - binary_sensor.multisensor_motion
      - binary_sensor.front_door
      - binary_sensor.side_door
      - binary_sensor.garage_door
    exclude_domains:
      - alarm_control_panel
      - alert
      - automation
      - binary_sensor
      - camera
      - climate
      - cover
      - fan
      - group
      - input_boolean
      - input_number
      - image_processing
      - light
      - lock
      - media_player
      - scene
      - script
      - sensor
      - switch
      - timer
      - vacuum

EDIT: Edited to correct indentation to prevent someone from copying the wrong one…

There are actually instructions for a test I must have missed on the page… but now I am concerned the “test” may actually discovery devices as I am still unsure what is wrong with my filter…

“Test the Lambda function”

So I was definitely able to test it with the Lambda test function mentioned in the docs, but had to set DEBUG=true in the environment variables or it just gave a 401 error… so it listed ALL of my devices still… filter still not working
I had my “alexa:” config as an !include in my configuration.yaml… moved it directly to my configuration.yaml and now the filter is working!!

That means the configuration was incorrect inside your include. Here’s what I have:

configuration.yaml

alexa: !include alexa.yaml

alexa.yaml

  smart_home:
    filter:
      include_entities:
        - fan.bonus_room_bedroom
        ... etc ...
    entity_config:
      fan.bonus_room_bedroom:
        name: Bonusroom Fan
      ... etc ...

My guess is that your spacing was off at the smart_home level.

1 Like

So I needed to indent the whole include probably and didn’t? (I will look at what I had when I get back in the house) I just assumed that because the first few lines were working that the whole thing was correct…