JY-GZ-01AQ smoke detector lost connection

I have a aqara JY-GZ-01AQ smoke detector.
I try to integrate it with zigbee2mqtt and its easly and apears easy in zigbee2mqtt and in mqtt home assistant.

the problem is that this device lost the connection with zigbee2mqtt after 24hours aprox.

anyone have the same problem?
i see this problem in the zigbee2mqtt github isues, but no have much movement

Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage.
The usual cause for disconnects is a zigbee mesh network that needs more routing devices.

1 Like

Thanks for your reply.
This is not the case. My network have a lot of devices and routers.
I have more than 80 devices and all works perfect.
This device is at one meter of coordinator, because Im testing it.
And allways disconect after 24 hours


I think is a problem with this device but i will like to talk with other users with this device to confirm that its a device issue

Then I would throw it away.
It’s a safety item, if you can’t count on it, it is of no use.

Yes, if i cant solve this issue, i will throw it away

Hello, I have the same issue, I have two of them connected with ZHA but exactly the same problem.
They work fine and fire the alarm when there is smoke, but they loses the connection with HA after some hours. Where did you buy it?
Please, let me know if you find a solution

hello again.
I make one test this days and it seams to work.
I launch a selftest action once per day. before 24 hours.
I must push the selftest buton 2 times, one push, wait 30 seconds and push again.

after the second push, the device sounds 3 times.

I make a automation that make this at 11:00 and at 20:00.
push button
wait 30sg
push button again

in the next few days I report to this topic if this works

1 Like

That is great news. I am also trying things but none of them worked.

If that automation works for you, I would appreciate if you can share it (that it works)


After 3 days with the device online.
Today apears offline again. I dont understand this device!!!

Where did you buy it? My guess is that it should be some firmware version. I bought it in TomTop or something like that.

The problem with that fix is the noice that it actually makes for selftest (my kids thought there was smoke).
I’m trying similar solution but enabling/disabling the silent on the alarm.

Another thing I realised (not sure if it happened to you) is that sometimes the device appears twice in my device list, one of them working one of them not.

I bought in aliexpress and received a update via zigbee2mqtt ota updates.

In my case the noise of the test is not a problem because this will be place in my garage (if i can make it works!!!) :slight_smile:

Hello @DAVIZINHO , I saw you posted also here: JY-GZ-01AQ Going Offline every day · Issue #20268 · Koenkk/zigbee2mqtt · GitHub

I have updated today the firmware of my coordinator to 20230507 (Sonoff), since people there say that it solved the issue for them.

I’ll keep you posted, but maybe it is worthy if you check the firmware version of your coordinator (I had a 2021xxxx)

Hi Man.
My coordinator is a conbee but if your update solve the problem I will inform the conbee People about this.

Thanks for the info, o keep waiting your progress

I found this, in case of that helps https://deconz.dresden-elektronik.de/deconz-firmware/?C=M;O=D Not sure, what version you have, it looks like the last one is deCONZ_ConBeeIII_0x26510900.bin.GCF 15-Apr-2024 12:21

hi again.
Yesterday, i look for new firmware and yes, a new version apears 10 days ago.
I updated today and repair de smoke sensor.
I report if this solve the problem!!!

1 Like

new firmware for conbee 3 not solve the problem.
Keeps online 2 days and after offline again.
I run a automation to make it sound twice per day. but lost conection too

this device makes me crazy

Sorry to hear about it.
Upgrading the firmware from my Sonoff Bridge solved the problem, now the devices are triggering the alarms and I am able to manage them properly from HA. Not issues since (it has been 2 weeks or maybe more).

1 Like