Keeping an HP wireless printer online/awake

So i’ve got a DeskJet 2700 All-in-One Printer. Not my choice but it’s what i’ve got. It’s wireless and the HP and the Internet Printing Protocol integration picks it up no problem.

The issue is that the printer has an auto off setting which is preset and unchangeable which is so frustrating. If i want to print something i have to head to the printer, power it back up, wait ages and hope it eventually decides to play ball and print.

I’m just wondering if anyone has any smart ideas of how to use Home Assistant to keep it awake. No wake on lan options but maybe theres a way to trick it into thinking a device is connecting to it briefly, not printing anything then stopping. Do this every hour or 2 and voila?

According to the manual you can change this setting with the embedded web server.

Find the printer its IP address and visit that with your browser.

Sadly not! The catch is if it’s wireless only then it can’t be changed. Which I think it’s nuts.

HOWEVER I took a shot at a guess and had HA ping the printer every 60 seconds overnight and voila it’s still awake this morning. Sometimes the simplest solutions are the best

2 Likes