Kemp load balancer reversed proxy

Hello there,
Anyone that has managed to setup home assistant behind kemp’s load balancer?
No matter what i do i don’t seem to get it to work.
All my other stuff works behind the balancer but HA doesn’t.
Any ideas?

I am interested too.
My scenario being a dev and prod instance behind it and capability to switch easily amongbtgem

Changed the ssl certs in the ssl folder, put my kemp in tcp connection only to homeassistant server and now it works like a charm :slight_smile:

I am having this same issue. I am able to get the verified connection to my Home Assistant server using TCP but am unable to access it from the Real Server address. Can you explain further what you mean by “changed the ssl certs in the ssl folder”? Was this done on HA or Kemp? Any additional information you can provide would be appreciated.

What i ment was that i put the ssl cert files from cloudflare in ssl folder in my HA instance.
I had it running via Duckdns before so i removed thoose Duckdns cert files and added my new ones from cloudflare.
And remember not to put in any portnumber when browsing to your Homeassistant when using kemp loadbalancer.

Thanks. I did something similar, putting the SSL files from Cloudflare in the SSL folder with a reference in the config:
ssl_certificate: /ssl/cert.pem
ssl_key: /ssl/privkey.pem
ip_ban_enabled: true
login_attempts_threshold: 5

When i rebooted with this config setting, i was completely shut out of the UI, even via the local IP. 400 Error via the named url and and 520 error going to the local.

Any advice? Thanks

Have your tried your local adress with https:// infront?
I personally removed the loadbalancer and access my homeassistant via cloudflared tunnel instead.

Here you have a link to one way to set it up: The Easiest Free Way To Do Home Assistant Remote Access! - YouTube

I personally runs my tunnel via docker on proxmox.

One way to get access is to ssh into your homeassistant and change the config.

Hope it helps.