KeyMaster Z-Wave lock manager and scheduler

I am unfortunately getting a similar error. Everything seems to work fine with my front door lock if I remove the single quotes from input_boolean.allow_automation_execution and input_boolean.allow_automation_execution in my scripts.yaml:

    #- service: homekit.start If you use homekit, uncomment this statement
    - service: input_boolean.turn_on
      entity_id: input_boolean.system_ready
    - service: input_boolean.turn_on
        entity_id: input_boolean.allow_automation_execution

    - service: input_boolean.turn_off
        entity_id: input_boolean.allow_automation_execution

However, my second (garage) lock is not functioning properly. I am getting the following errors in log:

Error while executing automation automation.garagesd_clear_code. Invalid data for call_service at pos 1: expected int for dictionary value @ data['code_slot']


Error rendering data template: str: Invalid entity ID 'input_text.garagesd_pin_'

If I run ‘lock.set_usercode’ from services tab with the following data:

node_id: 12
code_slot: 1
usercode: 1234

It seems to work. Obviously doesn’t change the code in lovelace but if I check through the zwave panel I can see the code has changed.

I removed the ’ ’ from those entity_id: sections and my errors went away, but none of the functionality is still working. I did notice some more of the ’ ’ in the _lock_manager_common.yaml file so you may want to check there and see if that resolves the issues for your other door locks.

I tried to run the ‘lock.set_usercode’ from the services tab and the ‘lock.get_usercode’ but they don’t work for me so i’m thinking there is something else that i’m missing also.

I used to use the code from here and that was working.

Yeah, I think my removing those actually did nothing… I found some better ways to debug and found it was a false positive. Anyhow, hate to say the obvious, but you’ve checked your entity ID naming, right?

I am unable to run ./

I get…

“bad interpreter: No such file or directory”

Any ideas? Thanks.

where are you trying to run it?

yeah i checked them over several times and no luck

Not sure what you mean. Ubuntu terminal I guess?

have you tried to install gawk? mentioned here:

Yes I saw that comment before and installed gawk via the apt install method.

I’ve been testing the code by adding notifications right after the trigger happens and I get the initial notification (Code Created step 1). However, I am not getting the notification that it’s finished (Code Created Done) after the service: lock.set_usercode section

    - alias: OutsideGarageDoor Add Code
        - condition: state
          entity_id: binary_sensor.allow_automation
          state: 'on' 
        entity_id: binary_sensor.active_outsidegaragedoor_1, binary_sensor.active_outsidegaragedoor_2, binary_sensor.active_outsidegaragedoor_3, binary_sensor.active_outsidegaragedoor_4, binary_sensor.active_outsidegaragedoor_5, binary_sensor.active_outsidegaragedoor_6
        platform: state
        to: 'on'
        - service: persistent_notification.create
            title: "debug"
            message: "Code Created step 1"
        - service: lock.set_usercode
            node_id: >- 
            code_slot: >-
                {% set object_id = trigger.to_state.object_id %}
                {% set index = 17 %}
                {% set code_slot = object_id[index:] %}
                {{ code_slot  }}
            usercode: >-
                {% set object_id = trigger.to_state.object_id %}
                {% set index = 17 %}
                {% set code_slot = object_id[index:] %}    
                {% set codetext = 'outsidegaragedoor_pin_' + code_slot | string %}
                {% set code = states['input_text'][codetext].state %}
                {{ code | string }}
        - service: persistent_notification.create
            title: "debug"
            message: "Code Created Done"

Forgot to ask, any errors in your log when running lock.set_usercode from your developer panel?

Not showing any errors when i use the developer panel.

That is super strange. Can you ensure that node_id is active and the default user codes are associated with it?

when i try to run the unlock using developer panel or even from Lovelace lock/unlock, the door locks and unlocks and it says unlocked from RF or something in that nature.

Have you verified you are using the correct node_id when calling the service from dev panel?

yes and i made sure the lock node id matches with the zwave one.

Hmmm… without seeing your lock-manager files, zwave setup, entity ID list, and logs… this is really tough to debug. It has to be something super small though. If you can find a way to post some of the above elsewhere, let me know… happy to dig further when I find some time.

I think i’ve configured everything correctly including adding the _frontdoor suffix to all my lock related entities as well as adding the “base lock” to the .ini. However, I’m getting the below referenced, “entity not available” issue. Has anyone dealt with or found a solution to this issue?


Hi! I thought I’d installed simplified Zwave lock manager correctly, but clearly something has gone wrong. Specifically, I’m getting several errors:

  1. HassIO is giving me: “Component error: system_ready - Integration ‘system_ready’ not found. Component error: allow_automation - Integration ‘allow_automation’ not found. Component error: input_boolean.system_ready - Integration ‘input_boolean.system_ready’ not found. Component error: allow_automation_execution - Integration ‘allow_automation_execution’ not found.” -->the instructions said to add these “to the existing configuration”–I assumed that was configuration.yaml, so I added them but this seems to be causing an issue.

  2. On the lock page of LoveLace, I get the following errors of entities not being found.
    “Entity not available: input_text.frontdoor_name_1…” etc. as some users have noted above.

Here’s my entity list:

And here’s my .ini file to configure this:

#See README for more information.

#number of PINS to setup in lovelace

#the name or location of the lock you are setting up (no spaces)

#the "lowest common denominator" of the factory lock name.

#The name of the (optional) door sensor.

#the "lowest common denominator" of the factory door sensor name.

#the Home Assistant EntityID of your (optional) garage door

Any ideas where I’m going wrong? Thanks for any insight ya’ll can provide!

post your relevant configuration.yaml file.