KeyMaster Z-Wave lock manager and scheduler

Honestly setting the index to -1 should fix it for any amount of characters, so I’d use that instead.


{% set index = -1 %}
1 Like

We have a winner! Thank you @firstof9

@tmman thanks for the @!
-1 worked!

{% set index = -1 %}

I am currently stuck on a similar issue that others had reported before: “entity not available” in the lovelace UI:

I have verified that my Schlage entities have the appropriate “_frontdoor” suffix (and did before I ran the setup script). I have verified that the lockfactoryname for my lock name is set correctly in the FrontDoor.ini file. I found that there was a reference in the frontdoor_lock_manager_common INI file that did not match the lockfactoryname for my device. I found this after running the setup script, so I’m wondering if I need to re-run the setup script?

Aside from that, I am fairly confident that I have set my binary sensors, input booleans, automations, and scripts correctly. I am not getting any errors from a config check at this point.

Likely you’ll need to re-run it.

Ok, I deleted the frontdoor folder that existed (which contained the yaml files and lovelace file). Re-ran the script, re-did the lovelace code…and I’m still getting the same error in lovelace.

I also double-checked the logs, and I’m not getting any errors. Core check runs clean as well.

I’m not sure what else to double-check or verify, so looking for some advice on where to look next.

Edit: here is a link to my configuration files:

It’s acting like frontdoor_lock_manager_1.yaml isn’t getting loaded.

Thanks for the reply. Any idea what would prevent that? Or how to test that theory?

Also, for reference I’ve checked core logs, supervisor logs, and ozw logs, and do not see errors at this point.

You are putting the files in the packages directory?

Well, /packages/lockmanager:

And you have the required entry in configuration.yaml?

packages: !include_dir_merge_named packages/
1 Like

I did not have that. I remember reading up on that, but must have overlooked it. Thanks for calling that out.

After adding…

  packages: !include_dir_merge_named packages/

…I am now getting a bunch of config errors that I will need to debug. Just to confirm, is the format as I entered it correct? Is the “homeassistant” header referring to a folder in the path? Or is just a naming convention item? I want to at least make sure that I’ve added the entry correctly to config.yaml.

That config looks fine like that.



@whymca not sure if you’re still dealing with the issue above but, this fixed my issue. Worth a check to see if you may have overlooked that, like I did.

Thanks. I’ve had no luck debugging my errors. It seems this is the primary issue:

Error: Testing configuration at /config
Failed config
    -expected a dictionary for dictionary value @ data['packages']['automation']
    -packages: [source /config/configuration.yaml:30]
      automation: [source /config/packages/lockmanager/frontdoor/frontdoor_lock_manager_common.yaml:132]
        -action: [source /config/packages/lockmanager/frontdoor/frontdoor_lock_manager_common.yaml:150]
          -data_template: [source /config/packages/lockmanager/frontdoor/frontdoor_lock_manager_common.yaml:152]

The log then proceeds to puke out a couple hundred lines of code from various files (mostly from the frontdoor_lock_manager_common.yaml).

From the digging I’ve done, it seems that an error of “expected a dictionary value…” generally means some yaml code is bad somewhere (spacing, formatting, etc). I’ve pored over my configuration, automations, scripts, and the frontdoor_lock_manager_common yaml files, and I just don’t see what I’m missing.

I’ve updated my files here for reference:

Any suggestions or recommendations would be much appreciated.

Try changing to

packages: !include_dir_named packages

see if that helps clear it up.

1 Like

That did it!!! No errors in the logs and no errors in the UI. I would buy you a beer if I could!

Maybe a DM would be a better place to discuss this, but I’d like to understand why removing merge from the packages command made a difference? From the HA documentation, I understand that including merge allows to have sub-folders, and that’s why I thought it was necessary…since I have subfolders within packages. Is it because there is only one package currently (lockmanager)? Or something else?

I don’t fully recall, but I use merged on my themes directory due to the themes having titles in their configuration.

I think I spoke too soon. I’ve got the GUI and the interface my Yale lock fully working. However, I’m not getting notifications when a code is accessing the lock. Instead I’ve got this in my log:

* frontdoor Notifications: Error executing script. Service not found for call_service at pos 1: Unable to find service script/conditional_notify
* frontdoor User Notifications: Error executing script. Service not found for call_service at pos 1: Unable to find service script/manual_notify

Seem like I’m missing a script but I’ve been back through the documentation a couple of times now and I think I’ve included all of the .yaml entries that were documented. Anybody have any ideas?

Did you ever get around this issue?

Thanks! This worked for me