Kiosk Mode - How to enforce new lovelace interface as default

Although I aim to have HA control everything automatically without user assistant it turns out that every once in a while fellow home-mates want to have control over the system.

I created a nice lovelace interface with different tabs and different views for different users so they can only control what they need to based on this page.

Now I would like them to have control over home assistant using the HA App on their phone. You can enter the URL to the HA system there, but you can’t forward it to http://my.local.ip.address:8123/lovelace-yaml/control-panel

Maybe that is not necessary at all, but I do not want to give them access to the side panel on the left or any other lovelace interfaces. What is the best way to do that?

I did install the kiosk mode and it hides the side and/or header once you select the new lovelace interface lovelace.yaml in the sidebar. It shows that page and this page works as expected both in a browser on a PC and the HA App untill …

… you hit the back button. It brings you back to the default page, which is very useful to keep for further development acitivites. So I rather not delete that one or can I generate it again at every moment in time?

I’ve tried several settings both on the PC and the App, but none of them prevented me from returning to the default page.

In the lovelace settings page I can set the my new lovelace interface lovelace.yaml as the default page on this device, but there remains a check mark behind the default overview page that it is the default page. Is there some way to enforce that or am I missing out on something?

Once you go back the default overview page the sidebar is hidden and you can’t select the new lovelace interface anymore.

The new lovelace interface is a YAML page and I added in configuration.yaml as follows

  mode: storage
  # Add yaml dashboards
      mode: yaml
      title: YAML
      icon: mdi:script
      show_in_sidebar: true
      filename: lovelace.yaml

My simple tryout to test the lovelace.yaml looks like

title: Home Sweet Home

    hide_sidebar: true
#    ignore_entity_settings: true

  - title: Living Room
    path: control-panel?hide_sidebar&cache
    theme: dark-mode
      - type: entities
        title: Lights
          - entity: light.livingroom_left
            name: Light Couch
          - entity: light.livingroom_right
            name: Light TV 
          - entity: light.livingroom_fancylight
            name: Fancy Light
      - type: entities
          - entity: scene.livingroom_moodlights
            name: Moodlights
      - type: thermostat
        entity: climate.livingroom

  - title: Kitchen
      - type: entities