Known_devices.yaml not being created

So I have a install working well and slowly customising it but I don’t seem to have a ‘known_devices.yaml’ file in the config folder even though I’ve followed the instructions and have discovery, ios and device_tracker in my configuration.yaml file.

Any ideas why this isn’t showing up?

1 Like

known_devices.yaml can take some time to show up. DO you see any device_tracker entities in developer tools?

No, all I can see that relates to my device is iPhone battery and state.

Does anyone have an example config yaml showing what it should look like for iOS tracking?

Try creating your own known_devices.yaml file. it has helped me before on hassbian. Have not had the time to look at ios component on hassio yet.
In your configuration.yaml all you need is “ios:” (without “”)

Is there any updates on creating known_devices.yaml in hassio. I am having the same issues.

I have the same problem. I added these lines to my configuration.yaml

  - platform: netgear
    username: ***
    password: ***
      track_new_devices: True
      hide_if_away: False

No known_devices.yaml is created, also after some reboots and several hours.
I am running 0.73.1 on a raspberry 3 and have a Netgear R7000 router.

I see the following in the log:
2018-07-29 16:06:14 INFO (MainThread) [homeassistant.core] Bus:Handling <Event service_registered[L]: domain=device_tracker, service=see>
2018-07-29 16:06:14 INFO (MainThread) [homeassistant.setup] Setup of domain device_tracker took 32.5 seconds.
2018-07-29 16:06:14 INFO (MainThread) [homeassistant.core] Bus:Handling <Event component_loaded[L]: component=device_tracker>

2018-07-29 16:05:39 INFO (MainThread) [homeassistant.loader] Loaded device_tracker from homeassistant.components.device_tracker

Do I need to setup something with?

was this ever figured out? i am having the same issue. no known_devices.yaml folder is created after i added:

  - platform: actiontec
    username: admin
    password: !secret router_password
    interval_seconds: 10
    consider_home: 180
    track_new_devices: no

I have the same issue with 81.1 hassio on raspbian stretch with noobs per raspberry pi 3. Probably unrelated, but I cannot get my duckdns url to work or the ios app, but I can get my hassio/pi IP address to work locally on 8123 in the front end and 3218 for configurator in the backend. There are just so many similar cases on the web and I have been over most of them multipule times if anyone can point me to a good thread for remote access with the hassio duckdns addon.

Same issue here.

I have the same issue. No errors in the log at all, just nothing populates “known-devices.yaml” (which I’d created manually from the configurator, since it wasn’t getting automatically created which that fact was causing errors).

Any ideas?

Update: After several hours trying everything, it suddenly worked. All my devices are in there now, except the new ones that I was working on most recently. I have owntracks and mqtt set up and basically working – for example, I can create an MQTT input node in Node-Red and attach a debug node to it. When I do a manual position update in the ios Owntrack app, the message shows up in the debug window. But, no devices showing up. I’ve tried a lot of variations of:

  port: xxxx
  username: !secret mqtt_username
  password: !secret mqtt_password
  client_id: home-assistant

  max_gps_accuracy: 100
  waypoints: true
  mqtt_topic: "owntracks/#"
  events_only: true

in configuration.yaml. And, in device_trackers I’ve tried lots of variations of:

- platform: mqtt

- platform: owntracks

(with various options settings, and no options like above)

and still no device trackers related to MQTT or Owntracks are showing up in the know-devices.yaml file.

So…updated question: “Any ideas?” :slight_smile:

same problem. (