KODI and TV not showing in Entities list

Hello everyone,

I’m pretty new to HASS and I already saw a few wow-like situations, e.g. when my Deconz and Google Hub was discovered right after first start. That was cool, as well adding new sensors to deconz make them appear automagicaly in HASS.
On the other hand, I also encountered few wtf-like moments that left me pretty confused. Last few hours I’m trying to add KODI to HASS. I read on kodi integration page that it should be auto-discovered, but I couldn’t find it anywhere. I tried to add discovery: to my config.yaml, but still no luck. I checked Config -> Devices and Config -> Entities, but no sight of Kodi. I added manual setup in config.yaml for Kodi and restarted HASS of course, but I still wasn’t able to find it.
I almost gave up when I tried to add Media control card to lovelace and got surprised that it offers me Kodi as well as my Samsung TV I added 2 days ago and couldn’t find either since then. I then found out that in Developer Tools -> States I’m able to find much more Entities that I can see in Configuration -> Entities.

So the question is. Is that normal or is it a bug? Shouldn’t I see ALL entities in Config -> Entities, that is Kodi and Samsung TV as well? I’m not hating, just trying to understand the way it works. Anyway I can say it was pretty confusing for a newbie, so if someone could offer some explanation, I would be grateful.

Btw. I run hass.io on Rpi3 if that changes anything.

Thank you guys,