Kodi Android App: Can´t fetch data

Hi guys,

I just bought the Nvidia Shield “Console”. Everything went fine. Kodi is running smooth but i ran into a problem with the HA component. HA is unable to fetch the data from the Kodi (SPMC) App. So I tried to access the jsonrpc site on a browser which works.
I´m running SPMC v.16.4.1.

Does somebody has any idea?

First of all check the log of HA and set the log level to info. What exactly is the error message?

Also did you try the normal Kodi App? Same problem there? SPMC != Kodi



the log message is the typical “homeassistant.components.media_player.kodi: Unable to fetch kodi data” get the same on my htpc when its off.

I also tried the normal Kodi App with the same result.

Edit: Tried it on a Fire TV. Same Issue.

I have it working on my fireTV. Did you enable HTTP access? Do you have a password / user for Kodi?
Did you try it without user / password? Also could you show your config for it in HA?

HTTP access - check
Password/User disabled - check (tried with and without)

Works with my HTPC setup. I´m also able to connect to the web interface on my pc.

Okay that’s wierd. You don’t have a firewall or anything right?

Nope. Like I said its working with my HTPC running LibreELEC. But all my Android Boxes won´t.

Welp I’m out of ideas sorry :confused:
Edit: You have the latest version of ha yeah?

Sure 25.2 :slight_smile: Thanks for your help :slight_smile:

1 Like

Set your Kodi port to 80 instead of 8080 in Koddi settings and in your Yaml file.

Restart Kodi and then restart HA.

When I try to set it to 80 the “Webserver won´t boot” :frowning:

You are talking about setting it in the Kodi Android App correct?

Correct. It´s set to 8080 but when i try 80 the webserver won´t boot.

Chance the Kodi webserver port to 8080

It is. It´s set to 8080 and i can access it through my browser. Or have I misunderstood something?:confused: