Konnected : Sensors unknown after duckdns setup


Wondering if anyone can help. Have a konnected alarm panel with various sensors set up. Since I managed to get external access going again the konnected panel sensors are displaying their status as “Unknown”.

Not sure why. I’ve set the override API host URL to https://[home assistant ip address]:8123 restarted home assistant, but the sensors remain unknown.

I can ping the thing so assume its on my network. I am running firmware 2.3.5. Was working fine before I finally got external access via duckdns back up and running.

I’ve restarted home assistant, restarted the Konnected device, removed the integration hoping it would be detected. No luck. Can’t add it manually as I don’t know what port number to use.

Any ideas? I’d sure like to hear em.

*** update ***
Home assistant has recognised the Konnected Alarm Panel:

but it “failed to set up”: This is what I see in the logs:

Logger: homeassistant.config_entries
Source: helpers/network.py:116
First occurred: 12:59:36 (1 occurrences)
Last logged: 12:59:36

Error setting up entry Konnected Alarm Panel for konnected
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 327, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/konnected/__init__.py", line 260, in async_setup_entry
    await client.async_connect()
  File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 133, in async_connect
    await self.async_sync_device_config()
  File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 374, in async_sync_device_config
  File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 335, in async_desired_settings_payload
    self.hass.data[DOMAIN].get(CONF_API_HOST) or get_url(self.hass)
  File "/usr/src/homeassistant/homeassistant/helpers/network.py", line 116, in get_url
    raise NoURLAvailableError

Reconfigured all zones, restarted home assistant. All sensors remain in an “Unknown” state. :hot_face:

Victory! Re-flashed to firmware 3.0.1 and after much knashing of teeth and pulling of hair I got the thing back on the network and connected to Home Assistant.

Now to get wemo, alarmo, nanoleaf and reolink back up and I’m back in business!

So…I have the same problem. I was stuck on 2.x.x and had to reflash the 6 node panel. Its finally on Software 3.0.1 / FW 3.0.0 but I still get UNKNOWN in HA while HA shows Firmware 3.0.1

Should FW also be on 3.0.1? IS there an OTA I have to do? #Veryfrustrated

This new ‘unknown’ sensor status change came in a previous release of HA. It’s been plaguing AlarmDecoder users the last few weeks. Balloob has posted a fix for that in #65926. Still not quite pushed out the door for us yet.

It’s likely similar changes may be necessary for Konnected.

Does Konnected.io maintain their integration? Surprised they aren’t looking at this, or is that integration a derivative of the AlarmDecorder?

No, I’m certain they are separate integrations. Just saying, if that low-level sensor change impacted one alarm interface, it’s very likely impacting others.