KooGeek P1EU - Homekit Code Error


#1

HI… i´m trying to join Koogeek P1EU with Home Assistant, but always have the same error when send the Homekit password: “Incorrect HomeKit code for P1EU. Please check it and try again.”
the HomeKit code is ok.

any idea???
Thanks…


#2

Getting the same error here. First I got an error message that said This accessory is already paired to another device. Please reset the accessory and try again. I tried removing the P1EU from the Home app on iOS, and now I get your error instead.

I’ve set the log level to debug for HomeKit, and it only seems to give me a “socket timeout” error.


#3

Did you manage to get anywhere on this? I’m having the same issue with a Hunter Ceiling Fan (SIMPLEconnect). Discovered fine, complained about already being paired. Removed from pairing and now states: “Incorrect HomeKit code for SIMPLEconnect. Please check it and try again.”

Every so often it produces an error to the log:
ERROR (MainThread) [homeassistant.core] Error executing service <ServiceCall configurator.configure (c:4e18e69df8c246b5a7038c0328add736): configure_id=140274408875736-4, fields=code=(homekit code)>
Traceback (most recent call last):
File “/usr/src/app/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/usr/src/app/homeassistant/components/configurator.py”, line 221, in async_handle_service_call
call.data.get(ATTR_FIELDS, {}))
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/src/app/homeassistant/components/homekit_controller/init.py”, line 195, in device_config_callback
pairing_id)
File “/config/deps/lib/python3.6/site-packages/homekit/protocol.py”, line 94, in perform_pair_setup
resp = connection.getresponse()
File “/usr/local/lib/python3.6/http/client.py”, line 1331, in getresponse
response.begin()
File “/usr/local/lib/python3.6/http/client.py”, line 297, in begin
version, status, reason = self._read_status()
File “/usr/local/lib/python3.6/http/client.py”, line 258, in _read_status
line = str(self.fp.readline(_MAXLINE + 1), “iso-8859-1”)
File “/usr/local/lib/python3.6/socket.py”, line 586, in readinto
return self._sock.recv_into(b)
socket.timeout: timed out

Edit: The exception only occurs if I try to use a delimiter (-) between the numbers of the HomeKit code. No log entry if I just try the code (with or without spaces)