Kuna Camera Lights [Solved]


I found this repo on another thread that dates back to 2017 but the repo was last updated in Mar 2020 - https://github.com/marthoc/kuna and tried installing it on HA VM v 0.113.3 with following steps:

  1. Supervisor --> Add-on-store --> Using the “⋮” on top right side selected --> repository
  2. Copied “https://github.com/marthoc/kuna” for “Add Repository”, clicked “add”
  3. As you can see in the screenshot, the new repo got added as “unknown” unlike “Ring Livestream” and “HACS” which showed more descriptive headings…but anyhow moving on…
  4. Configuration check passed, restarted HA
  5. Under integration, “Kuna” cannot be found, I have looked for all combinations of the repo including “unknown” and scrolled through the entire list for integration manually but cannot find this entry.

Also checked the logs but there are no errors.

Please advise if I am doing anything wrong or where to look for possible signs of trouble or bad configurations.


You need to go to hass.io’s addon store, not the integration page, and install the plugin first.

Hi KTibow,

Thanks for your comment!
I noticed in few of the videos “Hass.io” link in the UI between links for “Developers Tools” and “Configuration” in the left side pane.

I installed HA on a VM using the VDI image provided and in my UI I see “Supervisor” link where “Hass.io” was expected, interestingly “Supervisor” link has the same tabs (Dashboard, Add-on Store, Snapshot and System) as Hass.io (see screenshot).

I just assumed these are same and probably just a re-labeling over versions but please correct me if I am wrong.


PS: I was adding the repo at this Add-on page where it does not seem to recognize the github repo.

I also noticed following lines in System Tab under Supervisor which may be an error that needs to be resolved as it is specific to the repo I just added,

But I have no idea what this one means!

You need to go to the Add-on store tab.

KTibow, yes you are correct about doing it on Add-on page. This is my 5th day with HA so please excuse my newbie research.

  • I installed a new version on Raspberry Pi4, the Hass.io tab label has been changed to “Supervisor” but the URL still shows “hass.io” so must be some sort of label upgrade.
  • I added another custom repo under “Hass.io” for Ring Livestream and after re-start it was visible under “Add-on” tab with the label that was provided in the “repository.json” file of the Ring Livestream repo.
  • I tried adding “https://github.com/marthoc/kuna” the same way but it did not show up under “Add-on” tab and System log still shows error retrieving this repo, so concluding that something is not configured right with this repo for now.

Thanks for pointing me in the right direction :+1:

It is not an addon, it is a custom component, quite a different thing.

It’s a custom component. Go to HACS, choose Components, and click on the menu in the upper right of HACS. Then choose Custom Repositories, and add it.

@nickrout & @KTibow - thanks for your comments.

It was not working due to my stupidity, I was moving files and folders (according to documentation) using terminal command line. I started Samba Share and dropped the folders using File Explorer and everything worked according to the repo documentation!

@marthocoo for publishing this repo, these Kuna lights turned out to be a really good investment with this integration :+1:

@PanMat no problem! @KTibow’s instructions are correct and will make it easier to update the component in the future…

@marthocoo I need to tweak the settings I originally set for stream interval and update interval but I cannot access these settings. I’d hate to start from scratch as I have few UI cards as well as automation working around these lights.

Is there a way to change these parameters once integration is up and running?

I tried adding the repository

to HACS and the error response is “Invalid Add-on repository!”
Is it me or is the HACS integration broken?

I think I had the same error when I was just typing “marthoc/juna” as custom repo URL, use the full URL including https and it installed for me.

yes it does. where are you placing the url? What category option are you using before pressing “Add”?

try clearing your browsing history or start an incognito session. The URL seems to be working, fyi.

See screenshot below, use the three dots on the top left side to add a custom repo.

All added fine, but I get no camera entities. Just motion and switches. Any ideas?

Getting the same problem with no camera entities. Anyone still getting the thumbnail notifications?

I got it working again following the info in this GitHub thread. I just had to tweak one line in the code.

I have three KUna lights and they are all working fine, I had to make a minor change in a line of code in the source that fixed the problem. Just check the github repo and the thread has the post to fix the code.