Kwikset 888 Missing Controls and Sensors

Trying to get a Kwikset 888 set up in a dockerized Home Assistant. My problem is the Controls and Sensor sections are missing when I use S0 encryption. If I use No encryption they show up but the lock/unlock is greyed out (which I expected since no encryption).
I’ve factory reset/set locking direction and included/excluded numerous times.
Anyone have ideas on this one ?

Home Assistant 2022.11.4
     ghcr.io/home-assistant/home-assistant:stable
Z-Wave JS UI 8.6.1
    zwavejs/zwave-js-ui:latest
HUSBZB-1 stick FW: v4.32

Is it possible it is not completing the interview. Try pair it to network and leave it a while

Are you using HA or zwavejs UI to pair and check this? Zwavejsui will be best

I’ve used both HA and Zwavejsui. I actually prefer the Zwaveui since I can see more of whats going on. I actually have 2 of the same locks, the one on the door has sat for right at 24 hours and nothing new has shown up. I also checked under Entities in HA hoping that they were set as disabled but no joy there either.

Generally these are from pairing issues. I have both 888 and 910 locks and they are very fussy to get setup.

First, did you try a re-interview from zwavejsui?

Screenshot from 2022-12-20 09-46-57

As far as pairing, these older S0 locks many times used “whisper pairing” to exchange the security keys. Meaning, if the lock is not removed and right next to the zstick (some have reported needing to actually duct tape the lock to the hub/zstick for initial pairing), the security keys won’t properly exchange and you won’t have proper communication with the lock. 99% of zwave devices are recommended to “pair in place”, but these older S0 locks are generally an exception to that, and require removal from the door, pairing at the zstick, then reinstall at the door and do a heal device to re-establish the routes.

Also try and follow the advice here:

Once properly paired, these are the sensors that should show in home assistant:

Screenshot from 2022-12-20 09-52-52

Screenshot from 2022-12-20 09-52-55

I’ve tried the re-interview multiple times in zwaveui. Also held the HUSBZB directly on the lock, waited 15 min still no controls or sensors, I tried on all sides of the lock. I’ve tried the guide also.
I’m going to try a different version of zwaveui tonight if I can. What version are you using ?
Thanks for the screenshots of what is supposed to be there.

I’m on the latest release of zwavejsui running in docker - 8.6.1, which looks to be the same as yours, but I included this lock many versions back over a year ago.

Was this lock new or used, or did you ever have it included with some other system? If this lock was previously paired with an alarm/security system, like Vivint, an anti-theft feature on the lock is activated so if it is stolen it can’t be included in a new system. The anti-theft feature cannot be cleared with a factory reset, and the only way to clear the anti-theft flag is to bring it back to that original system it was included with and properly exclude it from that system.

You can set the logs to silly/debug and try including again, then post the logs. That would confirm if anti-theft is active, or possibly show what the issue is.

So that’s it !! The lock was included with a Vivant system. I unfortunately had them at the home I recently sold. Was talking with the new owner and he gave them back to me in a box since he was just going to throw them away.
Is there no way to ‘refurb’ the lock to clear the anti-theft code?

Unfortunately not that I’m aware of. The only way to clear the anti-theft flag is with the original Vivint system they were included to. Is that system still around by any chance? Maybe if you reach out to Vivint they might be able to provide a solution.

If you can access the old Vivint system these are directions to clear the anti-theft

I may be able to get access to the old system after the 1st of the year. I will try that and follow up with the results. Thanks again for all your help!