Kwikset lock Z-Wave Log notifications for manual actions

I have a Kwikset Smartcode 910 Z-Wave lock, and while I can control it remotely without any issues from my Home Assistant (HA) web interface, when I perform actions directly on the physical lock itself, such as entering a code or manually opening the latch, I don’t see any corresponding entries in the Z-Wave log.

Any ideas or help would be appreciated.

My setup:

  • Kwikset Smartcode 910 Z-Wave lock (Firmware: 4.10)
  • Zoos S2 stick 700 (USB, Firmware: 7.18.3)
  • Home assistant (2024.2.5)
  • Z-wave JS UI (zwave-js-ui: 9.9.0, zwave-js: 12.4.4)
  • Keymaster
  • Z-wave log level set to: Debug

I have tried:

  • Factory reset of the Kwikset Lock
  • Excluding and including the lock
  • Re-Interviewing the Kwikset lock.
  • Clearing and re-creating the z-wave associations
  • Re-building routes
  • Changing the S2/S0 Keys
  • The door lock is 1 meter away from the Z-Wave USB stick. (there is no packet loss)

I attach an image to complement this information.

Is there anything else I can check? Is there any other log I should check? Should I try removing Keymaster in case its generating any issues?

Any ideas or help would be appreciated.

It won’t show code entry in device but it should show physical lock/unlock in HA.

Hi @tmjpugh, can you please provide more details on this.

FWIW I had a 910 lock that did the exact same thing. I eventually replaced it with a 914 that has worked flawlessly.

I had three and still have one 910 and never had any issues. I did check and the one I still have installed is not showing Z-Wave+ and is showing a lower firmware version in Z-Wave JS UI.

This might be a better fit to be open as a Github issue. There was an older issue around the same problem, but looks like it’s been closed.

Hi, I am running this lock with a 450241 Z-Wave+ module I purchased on eBay. This is the link to the chipset I am using. Maybe it can provide some insights:
Kwikset Z-Wave PLUS Module 450241 Home Connect Chip for Kwikset Smartcode Locks | eBay

I had the same issues. Migrating to an 800 series stick fixed it.

My apology. I confuse my 914 with 910

I don’t have a lot to add here, but I can confirm I’m running into the same issue. I replaced my Z-Wave setup with a new ZST39 stick and factory reset and re-added all my devices. I have a pair of the older Kwikset (non-plus) modules that worked mostly fine for years, but I wanted the whole network on Plus so I bought a pair of 450241 modules on eBay. Paired them directly beside the z-stick, Z-Wave JS shows S0 security and Plus on both, one shows up as Kwikset 910 and the other as a 912. Everything functions EXCEPT that manual operations don’t trigger an update. I confirmed the associations with the z-stick, experimented with routing, nothing in the debug logs so I’m out of ideas here. I could try an automation to periodically refresh the node status but that’s probably going to be hard on the battery life.