Kwimset z wave lock problem

Hello, I own a Kwikset 910 Z-Wave Deadbolt ( and had it connected to my Smartthings system working just fine. When I connected it to my Home Assistant system and clicked on ‘Lock’ it, the lock span backwards (I mean, it was unlocked and it span in the same unlock direction), I immediately remove the battery and connected back to my Smartthings system.
The problem is that when this happened, I tried to manually lock/unlock the doorlock and it becomes a little hard, like the gears are stuck in some point, I am able to lock/unlock but using some force. When I try to lock/unlock from my Smartthings app, the motor becomes crazy and stuck.
I am aware that my issues begun with a software problem, now I just want to know if there is a solution to my deadbolt so it could go back to normal. I would appreciate some help. Thanks

From the sounds of it you need to redo the lock “hanging” procedure listed in the manual.

i just tried that, but with no success, any idea why?? is this a problem with this particular lock or happened this before??

When you do a reset of the lock (at least with schlage), you have to use a code to unlock it one time before doing anything. That will cause the deadbolt to extend, then pull back. If you try to manually do anything before doing that, it feels like it stuck.

I believe that the 1st unlock after a reset is testing for how well the deadbolt fits, determining how far to exetend, etc.