Last update Hassio will not boot - dead - need some directions

I took the last update and now all I see is the Logo screen…No SSH… so Samba… Cannot ping its ip.
I could put an image on the SD card and start over with the raspberry pi but how do I restore the backups and also not loose the backups I made.
ANy ideas? directions. I cannot read the SD card on my win10 computors . If I have to start completely over from scratch again… I cannot . I do not have the time for that. I will have to simply abandon HA forever. Thanks

  1. Check your router, maybe HA has a new IP?
  2. Download a Linux Recovery CD/DVD Image and boot it to read the SD card and copy your config files.

oh… great ideas… thanks I do run static IP

I took a new sd card and installed newest Hassio and it is up BUT
I would like to pull a Snapshot off the old SD card which is in the USB lot now on the Raspberry pi.
I dont know how.

I got SSH and Samba going on the new… now to figure out how to get files off the old dead sd card onto the new sd card… the BACKUP folder I can only see one SambaShare… Config folder

Me too, not using hassio. Maybe you find something here:

Two days of trying and NO luck. This sucks
The original SD card that was running before the last uodate will not come up BUT I can read anything I want from it and I got my config.yaml and 3 Snapshots which do not work. I image a new SD card put the Snapshots on the new SD card… tell it t do a full wipe and put it back from the latest image that was running to 86.3 and let it do its thing but it never comes back… no way to get back in…no ssh or FTP or Samba…no Hassio

If I can find a 86.3 image and put that image on the SD card maybe that will work. Where is the .img ? please . I tried the two Source Code(s) but dont know what to do with them… Do I have to make an .img??

How do I make an image from this version so I can load my Snapshot because my snapshots dont work in newer code? I see the 2 source code zip files but they are not an IMG
Am I supposed to make an IMG from one of those source codes? thanks for your help

I can ping the address of the Pi but thats it… I have to give up… I dont know what else to do… no more HA for me i guess.

It is not the answer you are looking for, but have you ever considered running HA on decent hardware? Like an Intel NUC or maybe in a virtual machine on a server or on a nas?

I really feel that the pi is way too underpowered for Home Assistant and the fact that they work with SD cards is a dealbreaker for me. They tend to fail rather sooner than later. Could it be that your SD card just fails? The amount of read/write that Home Assistant does is massive and SD cards are generally not built for that kind of purpose.

Second, did this problem occur after an update? If yes, try reverting to a version that you know that worked for sure.

Yes… it failed on this last update.

Thats exactly what I am trying to do, revert to an older version but how? I dont have an image to flash. I want to go to 86.3.I was running just up to the newest code but my last Snapshot was on 86.3 so I want to start with that. I have other computers and laptops that I can use for HA but I dont want to start from scratch. I have my yaml file which should shorten things a lot.

I am using a brand new SD card and I flash this Current Version: 0.92.2 ( xxx.img) and it comes up right away but i cannot use my SnapShots with 92.2 code. How do I get IMG files from GitHub?

Here is the link… no IMG

Ok, I am not home right now so my time is limited, but try to revert to an older Home Assistant first.

Tbh I don’t know if it works for a setup with SD cards but seeing you use a new setup there is no harm in trying. Try the following in the console:

$ cd homeassistant
$ source bin/activate
$ pip3 install homeassistant==0.XX.X

Replace the XX.X with a desired version number.

Edit: if it works you could try this with your old SD card as well to see if it was the update that broke your setup or not.

If you want to copy the config you have on Github you could simply do this manually if you have set up samba, there is a faster way to do it but I have never tried it. I would suggest copying the files from github and to be fair, I’d copy only the necessary lines from configuration.yaml as many things have changed over the past few months. (I did it and it solved many of the little annoyances I had with the frontend).