Latest version of Companion App unable to connect to local HA server using SSL

I noticed one of my mounted tablets was having connection issues today. It reported an ssl issue and that I needed to check my connections. I’m using Letsencrypt and cert is valid. I confirmed this tablet was on the latest version of the companion app.

I was able to access from my PC without issues.

I checked my other tablet and it was working fine. I proceeded to update it to the latest version of the app and it too now reports:

“The Home Assistant Certificate authority is not trusted…”

So, seems to be an issue with the latest version of the app.

1 Like

I haven’t been able to dig into this that much yet. I’ve seen one other user post a review of the app indicating the same problem after the latest update, so I am not alone.

What I have discovered though is that the update is working fine on my 2 Samsung devices, but not my 2 Hauwei tablets. Those tablets I have mounted and using a local only user, so I thought that it might be it related to the user. But I tried the local user on my samsung tablet and it worked ok… So, now I’m wondering if it is sometthing specific to the Huaweis

thsoe devices may not know about the CA your certificate uses. Did your certificate recently update around the same time the app did? SSL issues are not ones that can be solved by the app but you should be able to import the CA into those devices to fix the issue. Every device has a different set of trusted CAs so there is variability there.

I’m using the letsencrypt addon, so I would have thought CA would be trusted, but I was wondering if it might be something like that. Though, when I took a look my cert had renewed Dec 9th so I was thinking that was probably not it. But maybe something updated on the Huweis that is affecting them not trusting the CA…

Do you have a different internal url from external url? Your certificate is only valid for a particular external domain, you can’t get a cert from let’s encrypt that’s valid for an internal domain like homeassistant.local if that’s what you’re using.

No, same URL. I run my own dns internally, though I should double check the names is resolving correctly on those devices, I’ll verify that tomorrow.

Yeah, so these two devices are running Android 7, so pretty sure this a certificate issue. Work around for now was to install the nginx proxy so I can have these local devices have non-ssl access and keep the ssl for external access. Will have to see if I can upgrade these with lineageOS maybe.

Installing the LE cert manually did the trick on a Android 6 device:


I did this and it works :slight_smile: … Android 6.0 on Lenovo tab2

Thank you. installing the certs solved the problem

Thank you! Uploaded the certs and the old Nexus 10 work again :hugs::pray:t2:

The only issue that remains is the need for the PIN or other way to lock the screen after installing the certs: I tried to remove the PIN but it is no more available because of the new certs installed.
Does anyone know a workaround? (Nexus 10 not rooted, original OS)

Thank you in advance! :hugs::pray:t2:

Thank you ! That worked on my Samsung Galaxy Tab S2 (Android 7.0)

It is nice to see many people who recycle the old tablets to do another good job, kudos! :hugs: :pray: