Layout Card showing no layout option

I am new to home assitant and I am running Home Assistant Core 2022.5.2 as docker container in IOTStack. I was able to install HACS and installed thomasloven / lovelace-layout-card using HACS.

Unfortunately I do not see the four new Layout Types and Layout option under the Dashboard Settings tab.

What am I doing wrong? do I need anything specific to be mentioned additionally in configurations.yaml?
Thank you for any hints.

1 Like

Your dashboard look a bit different than mine, so maybe you are using another theme pack, which might hide the layout card options.

@WallyR Thanks for replying.

No, the theme seems to be not the reason. I don’t see it even with default or Backend-selected. I did the recommended installation method using HACS. Not sure if the problem lies here. In the Installation page its mentioned to create some cards.js raw file if one goes the manual way and add it to resource section. The HACS based installation does not show such a file. Instead the resource section reads
/hacsfiles/lovelace-layout-card/layout-card.js?hacstag<some long umber>

Ok, then first clear your browsers cache and then restart HA completely.
Secondly read the common problem section here: Lovelace Plugins · thomasloven/hass-config Wiki · GitHub

I did clear my browser cache and restarted HA. But still does not work. I noticed that I don’t have a hacsfiles folder. Not sure why the HACS based installation did not create this. Instead the layout-card.js is stored under www/community/lovelace-layout-card/layout-card.js.

What is the correct URL definition for resources in this case?

Do I need to create such a folder and place the file there or is /hacsfiles and /local some kind of alias or symbolic link internal to home assistant?

I my browser console I find the following entry while loading the home screen
LAYOUT-CARD 2.4.1 IS INSTALLED <empty string> [layout-card.js:229:115]

Thanks for your reply.

Found the solution!! :smiley:

It was a known issue since HA 2022.3.X and was fixed by layout-card v2.4.2. I guess HACS looks only for latest tag and unfortunately GitHub latest Tag still points to older v2.4.1. I just replaced the layout-card.js contents with the v2.4.2 contents and Voila!!

Thanks for your efforts.

hmm, I use HACS and I have 2.4.2 installed.
I have recently have had issues with other HACS addons that was suddenly “rolled” back, like the HASS-Hue-icons (Backstepping in version? · Issue #155 · arallsopp/hass-hue-icons · GitHub)
If the same is an issue with Layout-card then you should raise an issue.

1 Like

I have the same problem that after installing the “Layout card” the options in the dialog are not visible. I did the installation via HACS and checked that the path in the sources is correct. I am running the latest version of HA 2022.11 and 2.4.4 of the layout card.

Clear browser cache and restart host, not just ha core.

Did a full reboot of the host en cleared the browser cache, but still the same issue. Did a reinstall of the plugin, no difference.

Have you followed the instructions on the github page for HACS installs?

I deleted everything and started again. Somehow I forgot something in the previous installation, because now it works. Thanks for the support Wally!!

If you can’t see a “LAYOUT” tab, check this:

In newer versions of HASS the “Layout Options” box does not have a “LAYOUT” tab.

The “LAYOUT” tab is now incorporated in the “SETTINGS” tab instead.

1 Like