Ld2410 ble - hlk-ld2410b

I have wired motion sensors across my house, which are like 20 years old and just disconnected. I wanted to just put these little things inside and call it a day using BT. I have the whole hose covered with BT signal, but those little sensors are not possible to connect unless they are in the same room as the proxy :confused: .

My range was terrible initially when my BT dongle was plugged directly into the USB port of my HA. I put my BT dongle on a 6ft USB extension away from my HA device. Now I’m getting reception within the same room (~40ft). But, it drops as soon as there is not a clear line-of-sight to the dongle. That’s consistent with my phone app to the RADAR.

1 Like

I skipped the BLE and started using a esp works much better now

does anyone know what side up gives the best wide range

I get around 5-6m range with a LD2410c in a 3d printed enclosure. I have the metal rectangle areas facing out.

Just curious info. The first two LD2410B devices that connected with the LD2410 BLE integration show up with their MAC addresses in the identifiers. These two were discovered while connected (powered) by the USB “Kit” board. The third LD2410B was discovered while powered by 5 VDC but not connected to the USB “Kit” board. This third unit did not show up with the MAC address but was identified as HLK-LD2410B-6085. Minor difference but curious. May or may not be related but the first two connected first try. But the third device failed to connect twice. I rebooted HA and it connected on the third try.

I did try and wire up to a d1 mini but I think I have a defective unit as it refuses to play ball with the d1. I’ve tried the esphome code with both TX/RX pins and with D7 and D8 to no avail. It powers fine as I can see it in the app but it leaves all sensors as “unknown” in HA. Perhaps the price comes with a certain level of quality control…

I have the same problem. Had 3 other LD2410 connected to an esp32c3 and they work like a charm. Connect a LD2410B to a D1 mini v3 but all entities say “Unknown”. Also connect a LD2410C to the same D1 mini v3. Also all entities “Unknown”. Connected the same LD2410B to a esp32c3 and bingo. So somehow not all D1 mini v3’s seem to work with the LD2410B/C.

Very odd! I’ve tried a v2 and v3 D1 mini to no avail. I do have the ESP32 acting as a bluetooth proxy I could retry with instead, if I can bring myself to opening it all up again. Just a bit of a pain having to solder a usb breakout to the LD and ESP32 thanks to the lack of 5V pin.

Phil (or any other who knows…), where did you get an English version of (android) phone app? I’m looking… and all i get is chinese one…

First link in the first post will take you to the Hi-Link google drive. LD2410 esphome tips

I must be missing something here… it’s a second “tip” for that page i received, but when i download apk (it’s version 1.08), remove “i” at the end and install it on my phone it’s in chinese and i can’t find where (if possible) to change it into english…
But, my phone is not in english, but slovenian…perhaps this could be the culprit…?

This solved the problem for me (using other GPIO pins). Don’t connect the ld2410 to your D1 mini while flashing via the usb connector, otherwise it will not recognize the board.

Updated to the latest version of firmware. And it still lets me connect to them via Bluetooth to home Assistant. But now I cannot enable the sensors. Anybody else having this issue?

Detection Distance
Moving Target Distance
Moving Target Energy
Static Target Distance
Static Target Energy

I can’t get those entities either.
I have not updated yet. Is that a requirement for those entities?

To get these:
Detection Distance
Moving Target Distance
Moving Target Energy
Static Target Distance
Static Target Energy

After you have these recognized by the LD2410BLE HACS app, click on the MAC address in the LD2410BLE app windows in settings/Devices & Services. Then click on “1 Device” and a window will pop up and show the detectors. In the top part of the window you will see two sensors, Motion and Occupancy working. There will be five sensor outputs that are not activated. Click on the first one and then click on the settings wheel at the top. Then click on Enable, Ok then update. It will take a few seconds to update (refresh the page) and you will see the output. Do the same for the other 4.
I did not mess with the gates in the bottom part of this setup window.

I have been running three LD2410B detectors using BLE. I just received some LD2410C sensors and compiled a tasmoto bin for a mini D1 V3. After wiring up:
Mini-Di LD2410C
5VDC ----- Vcc
Gnd ---- Gnd
TX ---- TX
RX ---- RX

Tasmota settings
Configure Generic (18)
TX GPI01 - - - - LD2410 RX
RX GPI03 - - - - LD2410 TX

LD2410 Moving Distance - - - 210 (These distances vary of course)
LD2410 Static Distance - - - 185
LD2410 Detect Distance - - - 240

    • it worked. Here’s where it gets weird. I then when back to tasmota config and set up MQTT. After returning to the main menu. The distance results above were all zeros. They never worked again. I never touch the devices, just configurated the MQTT settings.
      After checking wires and all setting to see if something had changed I found no issues.
      1 hour later I had given up and decided to try a new LD2410C.
      I first erased all the MQTT settings I had changed.
      I removed power (USB connector), removed the LD2410C and replaced it with a different LD2410C, checked all connections and then plugged the USB cable back in. The new sensor worked as it should, like the first. I then set up MQTT again and returning back to the main menu, the sensor no longer was reporting, like the first! Really strange.
      With either of these LD2410C devices after they worked, then didn’t work after MQTT configuration, they continued to not work after erasing the MQTT configuration and rebooting.
      I should also note that the BLE output on both of these units continued to report without issue.

So has anyone had this issue? Am I doing something dumb here that I am not seeing?
Appreciate the help…

7:30PM Update This configuration also works (On my third LD2410C but the other two still do not)
Mini-Di LD2410C
5VDC ----- Vcc
Gnd ---- Gnd
TX ---- RX
RX ---- TX

Tasmota settings
Configure Generic (18)
TX GPI01 - - - - LD2410 TX
RX GPI03 - - - - LD2410 Rx

Also tried a configuration reset and reprogramming the Mini D1 again. No joy…
Looks like the first two LD2410C devices are no longer communicating through Rx/TX.

Waiting for D1s to arrive. Connected LD2420Cs to a USB UART and all 4 worked. Not sure what is going on with the D1. Will recompile another bin for the LD2410 and give it another try.

For non working UART, this worked for me:

swapped over to using RX = GPIO13/D7 and TX=GPIO15/D8

Hello, need change local to English on Phone, then app will be English.

Yes, i figured it out, thanks!
Luckily i have an iPad in english, so i use app there and i don’t need to switch language on my phone each time i want to change something.